USN-3114-2
USN-3114-2 · nginx regression
This page contains facts from public vulnerability sources. Check the original advisory before updating.
USN-3114-1 fixed a vulnerability in nginx. A packaging issue prevented nginx from being reinstalled or upgraded to a subsequent release. This update fixes the problem. We apologize for the inconvenience. Original advisory details: Dawid Golunski discovered that the nginx package incorrectly handled log file permissions. A remote attacker could possibly use this issue to obtain root privileges.
Fix available
- Published
- Updated
Affected products and versions
nginx Ubuntu:14.04:LTS
- Versions
- 1.4.1-3ubuntu1
- 1.4.3-2ubuntu1
- 1.4.4-1ubuntu1
- 1.4.4-2ubuntu1
- 1.4.4-4ubuntu1
- 1.4.5-1ubuntu1
- 1.4.6-1ubuntu2
- 1.4.6-1ubuntu3
- 1.4.6-1ubuntu3.1
- 1.4.6-1ubuntu3.2
- 1.4.6-1ubuntu3.3
- 1.4.6-1ubuntu3.4
- 1.4.6-1ubuntu3.5
- 1.4.6-1ubuntu3.6
- Affected ranges
- ECOSYSTEM: < 1.4.6-1ubuntu3.7
Update to 1.4.6-1ubuntu3.7
nginx Ubuntu:16.04:LTS
- Versions
- 1.9.3-1ubuntu1
- 1.9.6-2ubuntu1
- 1.9.6-2ubuntu2
- 1.9.9-0ubuntu1
- 1.9.9-1ubuntu1
- 1.9.10-0ubuntu1
- 1.9.10-1ubuntu1
- 1.9.11-0ubuntu1
- 1.9.11-0ubuntu2
- 1.9.12-0ubuntu1
- 1.9.13-0ubuntu1
- 1.9.14-0ubuntu1
- 1.9.15-0ubuntu1
- 1.10.0-0ubuntu0.16.04.1
- 1.10.0-0ubuntu0.16.04.2
- 1.10.0-0ubuntu0.16.04.3
- Affected ranges
- ECOSYSTEM: < 1.10.0-0ubuntu0.16.04.4
Update to 1.10.0-0ubuntu0.16.04.4