p PatchFirst

PatchFirst · Latest vulnerabilities

nginx vulnerabilities

Vulnerabilities published for nginx in the last 30 days: 0. Listed in the KEV catalogue: 0.

Filter vulnerabilities
Clear filters

Vulnerabilities: 9

  1. CVE-2018-16845

    High · CVSS 8.2EPSS 9.84%Fix available

    CVE-2018-16845

    nginx before versions 1.15.6, 1.14.1 has a vulnerability in the ngx_http_mp4_module, which might allow an attacker to cause infinite loop in a worker process, cause a worker process crash, or might result in worker process memory disclosure by using a specially crafted mp4 file. The issue only affects nginx if it is built with the ngx_http_mp4_module (the module is not built by default) and the .mp4. directive is used in the configuration file. Further, the attack is only possible if an attacker is able to trigger processing of a specially crafted mp4 file with the ngx_http_mp4_module.

    • Update to 1.4.6-1ubuntu3.9
    Published Updated
  2. CVE-2016-1247

    High · CVSS 7.8EPSS 4.86%Public exploitFix available

    CVE-2016-1247

    The nginx package before 1.6.2-5+deb8u3 on Debian jessie, the nginx packages before 1.4.6-1ubuntu3.6 on Ubuntu 14.04 LTS, before 1.10.0-0ubuntu0.16.04.3 on Ubuntu 16.04 LTS, and before 1.10.1-0ubuntu1.1 on Ubuntu 16.10, and the nginx ebuild before 1.10.2-r3 on Gentoo allow local users with access to the web server user account to gain root privileges via a symlink attack on the error log.

    • Update to 1.4.6-1ubuntu3.6
    Published Updated
  3. USN-3114-2

    Not ratedFix available

    nginx regression

    USN-3114-1 fixed a vulnerability in nginx. A packaging issue prevented nginx from being reinstalled or upgraded to a subsequent release. This update fixes the problem. We apologize for the inconvenience. Original advisory details: Dawid Golunski discovered that the nginx package incorrectly handled log file permissions. A remote attacker could possibly use this issue to obtain root privileges.

    • Update to 1.4.6-1ubuntu3.7
    Published Updated
  4. CVE-2016-0746

    Critical · CVSS 9.8EPSS 8.86%Fix available

    CVE-2016-0746

    Use-after-free vulnerability in the resolver in nginx 0.6.18 through 1.8.0 and 1.9.x before 1.9.10 allows remote attackers to cause a denial of service (worker process crash) or possibly have unspecified other impact via a crafted DNS response related to CNAME response processing.

    • Update to 1.4.6-1ubuntu3.4
    Published Updated
  5. CVE-2014-3616

    Not ratedEPSS 5.65%Fix available

    CVE-2014-3616

    nginx 0.5.6 through 1.7.4, when using the same shared ssl_session_cache or ssl_session_ticket_key for multiple servers, can reuse a cached SSL session for an unrelated context, which allows remote attackers with certain privileges to conduct "virtual host confusion" attacks.

    • Update to 1.4.6-1ubuntu3.1
    Published Updated

Check your server

Check your installed stack and versions against the current vulnerability feeds.

Check your server →