USN-3135-1
USN-3135-1 · gst-plugins-good0.10, gst-plugins-good1.0 vulnerability
This page contains facts from public vulnerability sources. Check the original advisory before updating.
Chris Evans discovered that GStreamer Good Plugins did not correctly handle malformed FLC movie files. If a user were tricked into opening a crafted FLC movie file with a GStreamer application, an attacker could cause a denial of service via application crash, or execute arbitrary code with the privileges of the user invoking the program.
Fix available
- Published
- Updated
Stack: system
Affected products and versions
gst-plugins-good0.10 Ubuntu:14.04:LTS
- Versions
- 0.10.31-3+nmu1ubuntu3
- 0.10.31-3+nmu1ubuntu4
- 0.10.31-3+nmu1ubuntu5
- Affected ranges
- ECOSYSTEM: < 0.10.31-3+nmu1ubuntu5.1
Update to 0.10.31-3+nmu1ubuntu5.1
gst-plugins-good1.0 Ubuntu:14.04:LTS
- Versions
- 1.2.0-1ubuntu1
- 1.2.1-1ubuntu1
- 1.2.1-1ubuntu2
- 1.2.2-1ubuntu1
- 1.2.3-1ubuntu1
- 1.2.3-1ubuntu2
- 1.2.4-1~ubuntu1
- Affected ranges
- ECOSYSTEM: < 1.2.4-1~ubuntu1.1
Update to 1.2.4-1~ubuntu1.1
gst-plugins-good1.0 Ubuntu:16.04:LTS
- Versions
- 1.6.0-1ubuntu1
- 1.6.1-1ubuntu1
- 1.6.2-1ubuntu1
- 1.7.1-1ubuntu1
- 1.7.2-1ubuntu1
- 1.7.90-1ubuntu1
- 1.7.91-1ubuntu1
- 1.8.0-1ubuntu1
- 1.8.1-1ubuntu0.1
- 1.8.2-1ubuntu0.1
- Affected ranges
- ECOSYSTEM: < 1.8.2-1ubuntu0.2
Update to 1.8.2-1ubuntu0.2