p PatchFirst

ALPINE-CVE-2024-38474

ALPINE-CVE-2024-38474

Diese Seite enthält Fakten aus öffentlichen Sicherheitsquellen. Lesen Sie vor dem Aktualisieren die Originalmeldung.

Substitution encoding issue in mod_rewrite in Apache HTTP Server 2.4.59 and earlier allows attacker to execute scripts in directories permitted by the configuration but not directly reachable by any URL or source disclosure of scripts meant to only to be executed as CGI. Users are recommended to upgrade to version 2.4.60, which fixes this issue. Some RewriteRules that capture and substitute unsafely will now fail unless rewrite flag "UnsafeAllow3F" is specified.

CVSS 9.8 · Kritisch · Korrektur verfügbar

Veröffentlicht
Aktualisiert

Technologie-Stack: system

Betroffene Produkte und Versionen

  • apache2 Alpine:v3.17

    Betroffene Versionsbereiche
    • ECOSYSTEM: < 2.4.60-r0

    Auf 2.4.60-r0 aktualisieren

  • apache2 Alpine:v3.18

    Betroffene Versionsbereiche
    • ECOSYSTEM: < 2.4.60-r0

    Auf 2.4.60-r0 aktualisieren

  • apache2 Alpine:v3.19

    Betroffene Versionsbereiche
    • ECOSYSTEM: < 2.4.60-r0

    Auf 2.4.60-r0 aktualisieren

  • apache2 Alpine:v3.20

    Betroffene Versionsbereiche
    • ECOSYSTEM: < 2.4.60-r0

    Auf 2.4.60-r0 aktualisieren

  • apache2 Alpine:v3.21

    Betroffene Versionsbereiche
    • ECOSYSTEM: < 2.4.60-r0

    Auf 2.4.60-r0 aktualisieren

  • apache2 Alpine:v3.22

    Betroffene Versionsbereiche
    • ECOSYSTEM: < 2.4.60-r0

    Auf 2.4.60-r0 aktualisieren

  • apache2 Alpine:v3.23

    Betroffene Versionsbereiche
    • ECOSYSTEM: < 2.4.60-r0

    Auf 2.4.60-r0 aktualisieren

  • apache2 Alpine:v3.24

    Betroffene Versionsbereiche
    • ECOSYSTEM: < 2.4.60-r0

    Auf 2.4.60-r0 aktualisieren

Originalquellen

Prüfen Sie Ihren Server →