p PatchFirst

ALPINE-CVE-2024-38474

ALPINE-CVE-2024-38474

Cette page présente des faits issus de sources publiques. Consultez l’avis original avant toute mise à jour.

Substitution encoding issue in mod_rewrite in Apache HTTP Server 2.4.59 and earlier allows attacker to execute scripts in directories permitted by the configuration but not directly reachable by any URL or source disclosure of scripts meant to only to be executed as CGI. Users are recommended to upgrade to version 2.4.60, which fixes this issue. Some RewriteRules that capture and substitute unsafely will now fail unless rewrite flag "UnsafeAllow3F" is specified.

CVSS 9.8 · Critique · Correctif disponible

Publication
Mise à jour

Pile logicielle: system

Produits et versions concernés

  • apache2 Alpine:v3.17

    Plages de versions concernées
    • ECOSYSTEM: < 2.4.60-r0

    Mettez à jour vers 2.4.60-r0

  • apache2 Alpine:v3.18

    Plages de versions concernées
    • ECOSYSTEM: < 2.4.60-r0

    Mettez à jour vers 2.4.60-r0

  • apache2 Alpine:v3.19

    Plages de versions concernées
    • ECOSYSTEM: < 2.4.60-r0

    Mettez à jour vers 2.4.60-r0

  • apache2 Alpine:v3.20

    Plages de versions concernées
    • ECOSYSTEM: < 2.4.60-r0

    Mettez à jour vers 2.4.60-r0

  • apache2 Alpine:v3.21

    Plages de versions concernées
    • ECOSYSTEM: < 2.4.60-r0

    Mettez à jour vers 2.4.60-r0

  • apache2 Alpine:v3.22

    Plages de versions concernées
    • ECOSYSTEM: < 2.4.60-r0

    Mettez à jour vers 2.4.60-r0

  • apache2 Alpine:v3.23

    Plages de versions concernées
    • ECOSYSTEM: < 2.4.60-r0

    Mettez à jour vers 2.4.60-r0

  • apache2 Alpine:v3.24

    Plages de versions concernées
    • ECOSYSTEM: < 2.4.60-r0

    Mettez à jour vers 2.4.60-r0

Sources originales

Vérifiez votre serveur →