ALPINE-CVE-2024-38474
ALPINE-CVE-2024-38474
This page contains facts from public vulnerability sources. Check the original advisory before updating.
Substitution encoding issue in mod_rewrite in Apache HTTP Server 2.4.59 and earlier allows attacker to execute scripts in directories permitted by the configuration but not directly reachable by any URL or source disclosure of scripts meant to only to be executed as CGI. Users are recommended to upgrade to version 2.4.60, which fixes this issue. Some RewriteRules that capture and substitute unsafely will now fail unless rewrite flag "UnsafeAllow3F" is specified.
CVSS 9.8 · Critical · Fix available
- Published
- Updated
Stack: system
Affected products and versions
apache2 Alpine:v3.17
- Affected ranges
- ECOSYSTEM: < 2.4.60-r0
Update to 2.4.60-r0
apache2 Alpine:v3.18
- Affected ranges
- ECOSYSTEM: < 2.4.60-r0
Update to 2.4.60-r0
apache2 Alpine:v3.19
- Affected ranges
- ECOSYSTEM: < 2.4.60-r0
Update to 2.4.60-r0
apache2 Alpine:v3.20
- Affected ranges
- ECOSYSTEM: < 2.4.60-r0
Update to 2.4.60-r0
apache2 Alpine:v3.21
- Affected ranges
- ECOSYSTEM: < 2.4.60-r0
Update to 2.4.60-r0
apache2 Alpine:v3.22
- Affected ranges
- ECOSYSTEM: < 2.4.60-r0
Update to 2.4.60-r0
apache2 Alpine:v3.23
- Affected ranges
- ECOSYSTEM: < 2.4.60-r0
Update to 2.4.60-r0
apache2 Alpine:v3.24
- Affected ranges
- ECOSYSTEM: < 2.4.60-r0
Update to 2.4.60-r0