p PatchFirst

CVE-2018-1000301

CVE-2018-1000301

Diese Seite enthält Fakten aus öffentlichen Sicherheitsquellen. Lesen Sie vor dem Aktualisieren die Originalmeldung.

curl version curl 7.20.0 to and including curl 7.59.0 contains a CWE-126: Buffer Over-read vulnerability in denial of service that can result in curl can be tricked into reading data beyond the end of a heap based buffer used to store downloaded RTSP content.. This vulnerability appears to have been fixed in curl < 7.20.0 and curl >= 7.60.0.

CVSS 9.1 · Kritisch · EPSS 5,9% · Korrektur verfügbar

Veröffentlicht
Aktualisiert

Technologie-Stack: system

Betroffene Produkte und Versionen

  • n/a

    Softwareversionen
    • n/a: Betroffen

    Keine Korrektur veröffentlicht

  • curl Debian:12

    Betroffene Versionsbereiche
    • ECOSYSTEM: < 7.60.0-1

    Auf 7.60.0-1 aktualisieren

  • curl Debian:13

    Betroffene Versionsbereiche
    • ECOSYSTEM: < 7.60.0-1

    Auf 7.60.0-1 aktualisieren

  • curl Debian:14

    Betroffene Versionsbereiche
    • ECOSYSTEM: < 7.60.0-1

    Auf 7.60.0-1 aktualisieren

  • curl Ubuntu:14.04:LTS

    Softwareversionen
    • 7.32.0-1ubuntu1
    • 7.33.0-1ubuntu1
    • 7.34.0-1ubuntu1
    • 7.35.0-1ubuntu1
    • 7.35.0-1ubuntu2
    • 7.35.0-1ubuntu2.1
    • 7.35.0-1ubuntu2.2
    • 7.35.0-1ubuntu2.3
    • 7.35.0-1ubuntu2.5
    • 7.35.0-1ubuntu2.6
    • 7.35.0-1ubuntu2.7
    • 7.35.0-1ubuntu2.8
    • 7.35.0-1ubuntu2.9
    • 7.35.0-1ubuntu2.10
    • 7.35.0-1ubuntu2.11
    • 7.35.0-1ubuntu2.12
    • 7.35.0-1ubuntu2.13
    • 7.35.0-1ubuntu2.14
    • 7.35.0-1ubuntu2.15
    Betroffene Versionsbereiche
    • ECOSYSTEM: < 7.35.0-1ubuntu2.16

    Auf 7.35.0-1ubuntu2.16 aktualisieren

  • curl Ubuntu:16.04:LTS

    Softwareversionen
    • 7.43.0-1ubuntu2
    • 7.45.0-1ubuntu1
    • 7.46.0-1ubuntu1
    • 7.47.0-1ubuntu1
    • 7.47.0-1ubuntu2
    • 7.47.0-1ubuntu2.1
    • 7.47.0-1ubuntu2.2
    • 7.47.0-1ubuntu2.3
    • 7.47.0-1ubuntu2.4
    • 7.47.0-1ubuntu2.5
    • 7.47.0-1ubuntu2.6
    • 7.47.0-1ubuntu2.7
    Betroffene Versionsbereiche
    • ECOSYSTEM: < 7.47.0-1ubuntu2.8

    Auf 7.47.0-1ubuntu2.8 aktualisieren

  • curl Ubuntu:18.04:LTS

    Softwareversionen
    • 7.55.1-1ubuntu2
    • 7.55.1-1ubuntu2.1
    • 7.57.0-1ubuntu1
    • 7.58.0-2ubuntu1
    • 7.58.0-2ubuntu2
    • 7.58.0-2ubuntu3
    Betroffene Versionsbereiche
    • ECOSYSTEM: < 7.58.0-2ubuntu3.1

    Auf 7.58.0-2ubuntu3.1 aktualisieren

Originalquellen

Prüfen Sie Ihren Server →