p PatchFirst

CVE-2018-1000301

CVE-2018-1000301

This page contains facts from public vulnerability sources. Check the original advisory before updating.

curl version curl 7.20.0 to and including curl 7.59.0 contains a CWE-126: Buffer Over-read vulnerability in denial of service that can result in curl can be tricked into reading data beyond the end of a heap based buffer used to store downloaded RTSP content.. This vulnerability appears to have been fixed in curl < 7.20.0 and curl >= 7.60.0.

CVSS 9.1 · Critical · EPSS 5.9% · Fix available

Published
Updated

Stack: system

Affected products and versions

  • n/a

    Versions
    • n/a: Affected

    No fix published

  • curl Debian:12

    Affected ranges
    • ECOSYSTEM: < 7.60.0-1

    Update to 7.60.0-1

  • curl Debian:13

    Affected ranges
    • ECOSYSTEM: < 7.60.0-1

    Update to 7.60.0-1

  • curl Debian:14

    Affected ranges
    • ECOSYSTEM: < 7.60.0-1

    Update to 7.60.0-1

  • curl Ubuntu:14.04:LTS

    Versions
    • 7.32.0-1ubuntu1
    • 7.33.0-1ubuntu1
    • 7.34.0-1ubuntu1
    • 7.35.0-1ubuntu1
    • 7.35.0-1ubuntu2
    • 7.35.0-1ubuntu2.1
    • 7.35.0-1ubuntu2.2
    • 7.35.0-1ubuntu2.3
    • 7.35.0-1ubuntu2.5
    • 7.35.0-1ubuntu2.6
    • 7.35.0-1ubuntu2.7
    • 7.35.0-1ubuntu2.8
    • 7.35.0-1ubuntu2.9
    • 7.35.0-1ubuntu2.10
    • 7.35.0-1ubuntu2.11
    • 7.35.0-1ubuntu2.12
    • 7.35.0-1ubuntu2.13
    • 7.35.0-1ubuntu2.14
    • 7.35.0-1ubuntu2.15
    Affected ranges
    • ECOSYSTEM: < 7.35.0-1ubuntu2.16

    Update to 7.35.0-1ubuntu2.16

  • curl Ubuntu:16.04:LTS

    Versions
    • 7.43.0-1ubuntu2
    • 7.45.0-1ubuntu1
    • 7.46.0-1ubuntu1
    • 7.47.0-1ubuntu1
    • 7.47.0-1ubuntu2
    • 7.47.0-1ubuntu2.1
    • 7.47.0-1ubuntu2.2
    • 7.47.0-1ubuntu2.3
    • 7.47.0-1ubuntu2.4
    • 7.47.0-1ubuntu2.5
    • 7.47.0-1ubuntu2.6
    • 7.47.0-1ubuntu2.7
    Affected ranges
    • ECOSYSTEM: < 7.47.0-1ubuntu2.8

    Update to 7.47.0-1ubuntu2.8

  • curl Ubuntu:18.04:LTS

    Versions
    • 7.55.1-1ubuntu2
    • 7.55.1-1ubuntu2.1
    • 7.57.0-1ubuntu1
    • 7.58.0-2ubuntu1
    • 7.58.0-2ubuntu2
    • 7.58.0-2ubuntu3
    Affected ranges
    • ECOSYSTEM: < 7.58.0-2ubuntu3.1

    Update to 7.58.0-2ubuntu3.1

Original sources

Check your server →