p PatchFirst

CVE-2020-11023

CVE-2020-11023 · Potential XSS vulnerability in jQuery

Diese Seite enthält Fakten aus öffentlichen Sicherheitsquellen. Lesen Sie vor dem Aktualisieren die Originalmeldung.

Diese Seite zeigt ausgewählte Angaben aus den Quellen. Die vollständige Beschreibung und betroffene Versionen finden Sie in den verlinkten Sicherheitshinweisen.

In jQuery versions greater than or equal to 1.0.3 and before 3.5.0, passing HTML containing <option> elements from untrusted sources - even after sanitizing it - to one of jQuery's DOM manipulation methods (i.e. .html(), .append(), and others) may execute untrusted code. This problem is patched in jQuery 3.5.0.

CVSS 6.9 · Mittel · EPSS 84,9% · Im KEV-Katalog · Öffentlicher Exploit · Korrektur verfügbar

Veröffentlicht
Aktualisiert

Technologie-Stack: system · php · node

Betroffene Produkte und Versionen

  • jquery

    Softwareversionen
    • >= 1.0.3, < 3.5.0: Betroffen

    Keine Korrektur veröffentlicht

  • node-jquery Debian:12

    Betroffene Versionsbereiche
    • ECOSYSTEM: < 3.5.0+dfsg-2

    Auf 3.5.0+dfsg-2 aktualisieren

  • node-jquery Debian:13

    Betroffene Versionsbereiche
    • ECOSYSTEM: < 3.5.0+dfsg-2

    Auf 3.5.0+dfsg-2 aktualisieren

  • node-jquery Debian:14

    Betroffene Versionsbereiche
    • ECOSYSTEM: < 3.5.0+dfsg-2

    Auf 3.5.0+dfsg-2 aktualisieren

  • znc Debian:12

    Softwareversionen
    • 1.10.1-1
    • 1.10.2-1
    • 1.10.3-1
    • 1.8.2-3.1
    • 1.8.2-3.1+deb12u1
    • 1.8.2-4
    • 1.9.0-1
    • 1.9.0-2
    • 1.9.1-1
    • 1.9.1-2
    Betroffene Versionsbereiche
    • ECOSYSTEM: (−∞, +∞)

    Keine Korrektur veröffentlicht

  • znc Debian:13

    Softwareversionen
    • 1.10.1-1
    • 1.10.2-1
    • 1.10.3-1
    • 1.9.1-2
    • 1.9.1-2+deb13u1
    Betroffene Versionsbereiche
    • ECOSYSTEM: (−∞, +∞)

    Keine Korrektur veröffentlicht

  • znc Debian:14

    Softwareversionen
    • 1.10.1-1
    • 1.10.2-1
    • 1.9.1-2
    Betroffene Versionsbereiche
    • ECOSYSTEM: < 1.10.3-1

    Auf 1.10.3-1 aktualisieren

  • jquery npm

    Betroffene Versionsbereiche
    • SEMVER: ≥ 1.0.3, < 3.5.0

    Auf 3.5.0 aktualisieren

  • jquery-rails RubyGems

    Softwareversionen
    • 0.1.1
    • 0.1.2
    • 0.1.3
    • 0.2
    • 0.2.1
    • 0.2.2
    • 0.2.3
    • 0.2.4
    • 0.2.5
    • 0.2.6
    • 0.2.7
    • 1.0
    • 1.0.1
    • 1.0.10
    • 1.0.11
    • 1.0.12
    • 1.0.13
    • 1.0.14
    • 1.0.15
    • 1.0.16
    • 1.0.17
    • 1.0.18
    • 1.0.19
    • 1.0.2
    • 1.0.3
    • 1.0.4
    • 1.0.5
    • 1.0.6
    • 1.0.7
    • 1.0.8
    • 1.0.9
    • 1.0.rc
    • 2.0.1
    • 2.0.2
    • 2.0.3
    • 2.1.0
    • 2.1.1
    • 2.1.2
    • 2.1.3
    • 2.1.4
    • 2.2.0
    • 2.2.1
    • 2.2.2
    • 2.3.0
    • 3.0.0
    • 3.0.1
    • 3.0.2
    • 3.0.3
    • 3.0.4
    • 3.1.0
    • 3.1.1
    • 3.1.2
    • 3.1.3
    • 3.1.4
    • 3.1.5
    • 4.0.0
    • 4.0.0.beta1
    • 4.0.0.beta2
    • 4.0.1
    • 4.0.2
    • 4.0.3
    • 4.0.4
    • 4.0.5
    • 4.1.0
    • 4.1.1
    • 4.2.0
    • 4.2.1
    • 4.2.2
    • 4.3.0
    • 4.3.1
    • 4.3.2
    • 4.3.3
    • 4.3.4
    • 4.3.5
    Betroffene Versionsbereiche
    • ECOSYSTEM: < 4.4.0

    Auf 4.4.0 aktualisieren

  • jquery NuGet

    Softwareversionen
    • 1.10.0
    • 1.10.0.1
    • 1.10.1
    • 1.10.2
    • 1.11.0
    • 1.11.1
    • 1.11.2
    • 1.11.3
    • 1.12.0
    • 1.12.1
    • 1.12.2
    • 1.12.3
    • 1.12.4
    • 1.4.1
    • 1.4.2
    • 1.4.3
    • 1.4.4
    • 1.5.0
    • 1.5.1
    • 1.5.2
    • 1.6.0
    • 1.6.1
    • 1.6.2
    • 1.6.3
    • 1.6.4
    • 1.7.0
    • 1.7.1
    • 1.7.1.1
    • 1.7.2
    • 1.8.0
    • 1.8.1
    • 1.8.2
    • 1.8.3
    • 1.9.0
    • 1.9.1
    • 2.0.0
    • 2.0.1
    • 2.0.1.1
    • 2.0.2
    • 2.0.3
    • 2.1.0
    • 2.1.1
    • 2.1.2
    • 2.1.3
    • 2.1.4
    • 2.2.0
    • 2.2.1
    • 2.2.2
    • 2.2.3
    • 2.2.4
    • 3.0.0
    • 3.0.0.1
    • 3.1.0
    • 3.1.1
    • 3.2.1
    • 3.3.1
    • 3.4.0
    • 3.4.1
    Betroffene Versionsbereiche
    • ECOSYSTEM: ≥ 1.0.3, < 3.5.0

    Auf 3.5.0 aktualisieren

  • org.webjars.npm:jquery Maven

    Softwareversionen
    • 1.11.0
    • 1.11.1
    • 1.11.3
    • 1.12.1
    • 1.12.2
    • 1.12.3
    • 1.12.4
    • 1.7.2
    • 1.7.3
    • 1.8.2
    • 1.8.3
    • 1.9.1
    • 2.1.0
    • 2.1.1
    • 2.1.1-rc1
    • 2.1.1-rc2
    • 2.1.3
    • 2.1.4
    • 2.2.0
    • 2.2.1
    • 2.2.2
    • 2.2.3
    • 2.2.4
    • 3.0.0
    • 3.0.0-alpha1
    • 3.0.0-beta1
    • 3.0.0-rc1
    • 3.1.0
    • 3.1.1
    • 3.2.0
    • 3.2.1
    • 3.3.0
    • 3.3.1
    • 3.4.0
    • 3.4.1
    Betroffene Versionsbereiche
    • ECOSYSTEM: ≥ 1.0.3, < 3.5.0

    Auf 3.5.0 aktualisieren

  • components/jquery Packagist

    Softwareversionen
    • 1.10.0
    • 1.10.1
    • 1.10.2
    • 1.11.0
    • 1.11.1
    • 1.11.2
    • 1.11.3
    • 1.12.0
    • 1.12.1
    • 1.12.4
    • 1.8.3
    • 1.9.0
    • 1.9.1
    • 2.0.0
    • 2.0.1
    • 2.0.2
    • 2.0.3
    • 2.1.0
    • 2.1.1
    • 2.1.3
    • 2.1.4
    • 2.2.0
    • 2.2.1
    • 2.2.4
    • 3.0.0
    • 3.1.0
    • 3.1.1
    • 3.2.0
    • 3.2.1
    • 3.3.1
    • 3.4.1
    Betroffene Versionsbereiche
    • ECOSYSTEM: ≥ 1.0.3, < 3.5.0

    Auf 3.5.0 aktualisieren

  • drupal7 Ubuntu:Pro:14.04:LTS

    Softwareversionen
    • 7.23-1
    • 7.24-1
    • 7.24-2
    • 7.26-1
    • 7.26-1ubuntu0.1
    • 7.26-1ubuntu0.1+esm1
    • 7.26-1ubuntu0.1+esm2
    Betroffene Versionsbereiche
    • ECOSYSTEM: < 7.26-1ubuntu0.1+esm3

    Auf 7.26-1ubuntu0.1+esm3 aktualisieren

  • drupal7 Ubuntu:Pro:16.04:LTS

    Softwareversionen
    • 7.38-1
    • 7.41-1
    • 7.44-1ubuntu1~16.04.0
    • 7.44-1ubuntu1~16.04.0+esm1
    • 7.44-1ubuntu1~16.04.0+esm2
    Betroffene Versionsbereiche
    • ECOSYSTEM: < 7.44-1ubuntu1~16.04.0+esm3

    Auf 7.44-1ubuntu1~16.04.0+esm3 aktualisieren

  • jquery Ubuntu:Pro:18.04:LTS

    Softwareversionen
    • 3.1.1-2
    • 3.2.1-1
    Betroffene Versionsbereiche
    • ECOSYSTEM: < 3.2.1-1ubuntu0.1~esm1

    Auf 3.2.1-1ubuntu0.1~esm1 aktualisieren

  • jquery Ubuntu:20.04:LTS

    Softwareversionen
    • 3.3.1~dfsg-3
    Betroffene Versionsbereiche
    • ECOSYSTEM: < 3.3.1~dfsg-3ubuntu0.1

    Auf 3.3.1~dfsg-3ubuntu0.1 aktualisieren

Originalquellen

Prüfen Sie Ihren Server →