p PatchFirst

PatchFirst · Aktuelle Sicherheitslücken

Sicherheitslücken in jquery

In den letzten 30 Tagen veröffentlichte Sicherheitslücken für jquery: 0. Davon im KEV-Katalog: 0.

Sicherheitslücken filtern
Filter zurücksetzen

Sicherheitslücken: 8

  1. CVE-2020-7656

    Mittel · CVSS 6.1EPSS 6,43%Öffentlicher ExploitKorrektur verfügbar

    CVE-2020-7656

    jquery prior to 1.9.0 allows Cross-site Scripting attacks via the load method. The load method fails to recognize and remove "<script>" HTML tags that contain a whitespace character, i.e: "</script >", which results in the enclosed script logic to be executed.

    • Auf 1.9.0 aktualisieren
    Veröffentlicht Aktualisiert
  2. CVE-2020-11023

    Mittel · CVSS 6.9EPSS 84,89%Im KEV-KatalogÖffentlicher ExploitKorrektur verfügbar

    Potential XSS vulnerability in jQuery

    In jQuery versions greater than or equal to 1.0.3 and before 3.5.0, passing HTML containing <option> elements from untrusted sources - even after sanitizing it - to one of jQuery's DOM manipulation methods (i.e. .html(), .append(), and others) may execute untrusted code. This problem is patched in jQuery 3.5.0.

    • Auf 3.5.0 aktualisieren
    Veröffentlicht Aktualisiert
  3. CVE-2020-11022

    Mittel · CVSS 6.9EPSS 99,22%Öffentlicher ExploitKorrektur verfügbar

    jQuery has a potential XSS vulnerability

    In jQuery starting with 1.12.0 and before 3.5.0, passing HTML from untrusted sources - even after sanitizing it - to one of jQuery's DOM manipulation methods (i.e. .html(), .append(), and others) may execute untrusted code. This problem is patched in jQuery 3.5.0.

    • Auf 3.5.0 aktualisieren
    Veröffentlicht Aktualisiert
  4. CVE-2019-11358

    Mittel · CVSS 6.1EPSS 86,82%Öffentlicher ExploitKorrektur verfügbar

    CVE-2019-11358

    jQuery before 3.4.0, as used in Drupal, Backdrop CMS, and other products, mishandles jQuery.extend(true, {}, ...) because of Object.prototype pollution. If an unsanitized source object contained an enumerable __proto__ property, it could extend the native Object.prototype.

    • Auf 3.4.0 aktualisieren
    Veröffentlicht Aktualisiert
  5. CVE-2016-10707

    Hoch · CVSS 7.5EPSS 3,23%Korrektur verfügbar

    CVE-2016-10707

    jQuery 3.0.0-rc.1 is vulnerable to Denial of Service (DoS) due to removing a logic that lowercased attribute names. Any attribute getter using a mixed-cased name for boolean attributes goes into an infinite recursion, exceeding the stack call limit.

    • Auf 3.0.0 aktualisieren
    Veröffentlicht Aktualisiert
  6. CVE-2015-9251

    Mittel · CVSS 6.1EPSS 29,73%Korrektur verfügbar

    CVE-2015-9251

    jQuery before 3.0.0 is vulnerable to Cross-site Scripting (XSS) attacks when a cross-domain Ajax request is performed without the dataType option, causing text/javascript responses to be executed.

    • Auf 1.12.2 aktualisieren
    • Auf 3.0.0 aktualisieren
    Veröffentlicht Aktualisiert
  7. CVE-2012-6708

    Mittel · CVSS 6.1EPSS 8,63%Öffentlicher ExploitKorrektur verfügbar

    CVE-2012-6708

    jQuery before 1.9.0 is vulnerable to Cross-site Scripting (XSS) attacks. The jQuery(strInput) function does not differentiate selectors from HTML in a reliable fashion. In vulnerable versions, jQuery determined whether the input was HTML by looking for the '<' character anywhere in the string, giving attackers more flexibility when attempting to construct a malicious payload. In fixed versions, jQuery only deems the input to be HTML if it explicitly starts with the '<' character, limiting exploitability only to attackers who can control the beginning of a string, which is far less common.

    • Auf 1.9.0 aktualisieren
    Veröffentlicht Aktualisiert
  8. CVE-2011-4969

    Nicht bewertetEPSS 19,19%Korrektur verfügbar

    CVE-2011-4969

    Cross-site scripting (XSS) vulnerability in jQuery before 1.6.3, when using location.hash to select elements, allows remote attackers to inject arbitrary web script or HTML via a crafted tag.

    • Auf 1.6.3 aktualisieren
    Veröffentlicht Aktualisiert

Prüfen Sie Ihren Server

Gleichen Sie Ihren installierten Stack und seine Versionen mit den aktuellen Sicherheitsmeldungen ab.

Prüfen Sie Ihren Server →