CVE-2021-21252
CVE-2021-21252 · Regular expression denial of service in jquery-validation
Diese Seite enthält Fakten aus öffentlichen Sicherheitsquellen. Lesen Sie vor dem Aktualisieren die Originalmeldung.
The jQuery Validation Plugin provides drop-in validation for your existing forms. It is published as an npm package "jquery-validation". jquery-validation before version 1.19.3 contains one or more regular expressions that are vulnerable to ReDoS (Regular Expression Denial of Service). This is fixed in 1.19.3.
CVSS 5.3 · Mittel · EPSS 3,6% · Korrektur verfügbar
- Veröffentlicht
- Aktualisiert
Technologie-Stack: system · node
Betroffene Produkte und Versionen
jquery-validation
- Softwareversionen
- < 1.19.3: Betroffen
Keine Korrektur veröffentlicht
phpmyadmin Debian:12
- Betroffene Versionsbereiche
- ECOSYSTEM: < 4:5.0.4+dfsg2-2
Auf 4:5.0.4+dfsg2-2 aktualisieren
phpmyadmin Debian:13
- Betroffene Versionsbereiche
- ECOSYSTEM: < 4:5.0.4+dfsg2-2
Auf 4:5.0.4+dfsg2-2 aktualisieren
phpmyadmin Debian:14
- Betroffene Versionsbereiche
- ECOSYSTEM: < 4:5.0.4+dfsg2-2
Auf 4:5.0.4+dfsg2-2 aktualisieren
jquery-validation npm
- Betroffene Versionsbereiche
- SEMVER: < 1.19.3
Auf 1.19.3 aktualisieren
jquery.validation NuGet
- Softwareversionen
- 1.10.0
- 1.11.0
- 1.11.1
- 1.12.0
- 1.13.0
- 1.13.1
- 1.14.0
- 1.15.0
- 1.15.1
- 1.16.0
- 1.17.0
- 1.19.1
- 1.19.2
- 1.6.0
- 1.7.0
- 1.8.0
- 1.8.0.1
- 1.8.1
- 1.9.0
- 1.9.0.1
- Betroffene Versionsbereiche
- ECOSYSTEM: < 1.19.3
Auf 1.19.3 aktualisieren
phpmyadmin Ubuntu:Pro:14.04:LTS
- Softwareversionen
- 4:4.0.6-1
- 4:4.0.8-1
- 4:4.0.9-1
- 4:4.0.10-1
- 4:4.0.10-1ubuntu0.1
- 4:4.0.10-1ubuntu0.1+esm1
- 4:4.0.10-1ubuntu0.1+esm2
- 4:4.0.10-1ubuntu0.1+esm3
- 4:4.0.10-1ubuntu0.1+esm4
- Betroffene Versionsbereiche
- ECOSYSTEM: (−∞, +∞)
Keine Korrektur veröffentlicht
civicrm Ubuntu:Pro:16.04:LTS
- Softwareversionen
- 4.7.1+dfsg-1
- 4.7.1+dfsg-2
- 4.7.1+dfsg-2ubuntu1
- 4.7.1+dfsg-2ubuntu1+esm1
- Betroffene Versionsbereiche
- ECOSYSTEM: (−∞, +∞)
Keine Korrektur veröffentlicht
otrs2 Ubuntu:16.04:LTS
- Softwareversionen
- 4.0.10-1
- 5.0.1-1
- 5.0.1-2
- 5.0.2-1
- 5.0.3-1
- 5.0.5-1
- 5.0.6-1
- 5.0.7-1
- Betroffene Versionsbereiche
- ECOSYSTEM: (−∞, +∞)
Keine Korrektur veröffentlicht
phpmyadmin Ubuntu:Pro:16.04:LTS
- Softwareversionen
- 4:4.4.13.1-1
- 4:4.5.0.2-2
- 4:4.5.1-1
- 4:4.5.1-2
- 4:4.5.1-3
- 4:4.5.2-1
- 4:4.5.2-2
- 4:4.5.3.1-1
- 4:4.5.4-1
- 4:4.5.4.1-2
- 4:4.5.4.1-2ubuntu1
- 4:4.5.4.1-2ubuntu2
- 4:4.5.4.1-2ubuntu2.1
- 4:4.5.4.1-2ubuntu2.1+esm2
- 4:4.5.4.1-2ubuntu2.1+esm3
- 4:4.5.4.1-2ubuntu2.1+esm4
- 4:4.5.4.1-2ubuntu2.1+esm5
- 4:4.5.4.1-2ubuntu2.1+esm6
- Betroffene Versionsbereiche
- ECOSYSTEM: (−∞, +∞)
Keine Korrektur veröffentlicht
civicrm Ubuntu:Pro:18.04:LTS
- Softwareversionen
- 4.7.23+dfsg-1ubuntu1
- 4.7.24+dfsg-1ubuntu1
- 4.7.30+dfsg-1ubuntu1
- 4.7.30+dfsg-1ubuntu1+esm1
- Betroffene Versionsbereiche
- ECOSYSTEM: (−∞, +∞)
Keine Korrektur veröffentlicht
otrs2 Ubuntu:18.04:LTS
- Softwareversionen
- 5.0.23-1
- 5.0.24-1
- 6.0.1-1
- 6.0.2-1
- 6.0.3-1
- 6.0.4-1
- 6.0.5-1
- Betroffene Versionsbereiche
- ECOSYSTEM: (−∞, +∞)
Keine Korrektur veröffentlicht
phpmyadmin Ubuntu:Pro:18.04:LTS
- Softwareversionen
- 4:4.6.6-5
- 4:4.6.6-5ubuntu0.2+esm1
- 4:4.6.6-5ubuntu0.2+esm2
- 4:4.6.6-5ubuntu0.5
- 4:4.6.6-5ubuntu0.5+esm1
- Betroffene Versionsbereiche
- ECOSYSTEM: (−∞, +∞)
Keine Korrektur veröffentlicht
civicrm Ubuntu:Pro:20.04:LTS
- Softwareversionen
- 5.11.0+dfsg-1
- 5.18.1+dfsg-1
- 5.20.3+dfsg-1
- 5.21.0+dfsg-1
- 5.21.1+dfsg-1
- 5.21.2+dfsg-1
- 5.21.2+dfsg-1ubuntu0.1~esm1
- Betroffene Versionsbereiche
- ECOSYSTEM: (−∞, +∞)
Keine Korrektur veröffentlicht
otrs2 Ubuntu:20.04:LTS
- Softwareversionen
- 6.0.20-1
- 6.0.23-2
- 6.0.24-1
- 6.0.25-1
- 6.0.25-2
- 6.0.25-3
- 6.0.26-1
- Betroffene Versionsbereiche
- ECOSYSTEM: (−∞, +∞)
Keine Korrektur veröffentlicht
phpmyadmin Ubuntu:Pro:20.04:LTS
- Softwareversionen
- 4:4.9.1+dfsg1-2
- 4:4.9.2+dfsg1-1
- 4:4.9.5+dfsg1-1ubuntu1
- 4:4.9.5+dfsg1-2
- 4:4.9.5+dfsg1-2ubuntu0.1~esm1
- Betroffene Versionsbereiche
- ECOSYSTEM: (−∞, +∞)
Keine Korrektur veröffentlicht
otrs2 Ubuntu:22.04:LTS
- Softwareversionen
- 6.0.32-6
- 6.1.2-1
- 6.2.1-1
- 6.2.2-2
- Betroffene Versionsbereiche
- ECOSYSTEM: (−∞, +∞)
Keine Korrektur veröffentlicht
civicrm Ubuntu:Pro:22.04:LTS
- Softwareversionen
- 5.33.2+dfsg1-1
- 5.33.2+dfsg1-1build1
- 5.33.2+dfsg1-1ubuntu1
- 5.33.2+dfsg1-1ubuntu1+esm1
- Betroffene Versionsbereiche
- ECOSYSTEM: (−∞, +∞)
Keine Korrektur veröffentlicht
Originalquellen
- https://github.com/jquery-validation/jquery-validation/security/advisories/GHSA-jxwx-85vp-gvwm
- https://github.com/jquery-validation/jquery-validation/pull/2371
- https://github.com/jquery-validation/jquery-validation/commit/5d8f29eef363d043a8fec4eb86d42cadb5fa5f7d
- https://www.npmjs.com/package/jquery-validation
- https://security.netapp.com/advisory/ntap-20210219-0005/
- https://lists.debian.org/debian-lts-announce/2023/08/msg00040.html
- https://nvd.nist.gov/vuln/detail/CVE-2021-21252