p PatchFirst

CVE-2021-27292

CVE-2021-27292

Diese Seite enthält Fakten aus öffentlichen Sicherheitsquellen. Lesen Sie vor dem Aktualisieren die Originalmeldung.

ua-parser-js >= 0.7.14, fixed in 0.7.24, uses a regular expression which is vulnerable to denial of service. If an attacker sends a malicious User-Agent header, ua-parser-js will get stuck processing it for an extended period of time.

CVSS 7.5 · Hoch · EPSS 3,4% · Korrektur verfügbar

Veröffentlicht
Aktualisiert

Technologie-Stack: system · node

Betroffene Produkte und Versionen

  • n/a

    Softwareversionen
    • n/a: Betroffen

    Keine Korrektur veröffentlicht

  • node-ua-parser-js Debian:12

    Betroffene Versionsbereiche
    • ECOSYSTEM: < 0.7.24+ds-1

    Auf 0.7.24+ds-1 aktualisieren

  • node-ua-parser-js Debian:13

    Betroffene Versionsbereiche
    • ECOSYSTEM: < 0.7.24+ds-1

    Auf 0.7.24+ds-1 aktualisieren

  • node-ua-parser-js Debian:14

    Betroffene Versionsbereiche
    • ECOSYSTEM: < 0.7.24+ds-1

    Auf 0.7.24+ds-1 aktualisieren

  • ua-parser-js npm

    Betroffene Versionsbereiche
    • SEMVER: ≥ 0.7.14, < 0.7.24

    Auf 0.7.24 aktualisieren

  • node-ua-parser-js Ubuntu:18.04:LTS

    Softwareversionen
    • 0.7.14-1
    Betroffene Versionsbereiche
    • ECOSYSTEM: (−∞, +∞)

    Keine Korrektur veröffentlicht

  • node-ua-parser-js Ubuntu:20.04:LTS

    Softwareversionen
    • 0.7.14-1
    Betroffene Versionsbereiche
    • ECOSYSTEM: (−∞, +∞)

    Keine Korrektur veröffentlicht

  • node-ua-parser-js Ubuntu:22.04:LTS

    Softwareversionen
    • 0.7.24+ds-1
    • 0.7.24+ds-2
    • 0.7.31+ds+~0.7.36-1
    Betroffene Versionsbereiche
    • ECOSYSTEM: (−∞, +∞)

    Keine Korrektur veröffentlicht

Originalquellen

Prüfen Sie Ihren Server →