CVE-2021-27292
CVE-2021-27292
Esta página presenta datos de fuentes públicas de vulnerabilidades. Consulta el aviso original antes de actualizar.
ua-parser-js >= 0.7.14, fixed in 0.7.24, uses a regular expression which is vulnerable to denial of service. If an attacker sends a malicious User-Agent header, ua-parser-js will get stuck processing it for an extended period of time.
CVSS 7.5 · Alta · EPSS 3,4% · Corrección disponible
- Publicación
- Actualización
Pila tecnológica: system · node
Productos y versiones afectados
n/a
- Versiones
- n/a: Afectada
Sin corrección publicada
node-ua-parser-js Debian:12
- Intervalos de versiones afectados
- ECOSYSTEM: < 0.7.24+ds-1
Actualiza a 0.7.24+ds-1
node-ua-parser-js Debian:13
- Intervalos de versiones afectados
- ECOSYSTEM: < 0.7.24+ds-1
Actualiza a 0.7.24+ds-1
node-ua-parser-js Debian:14
- Intervalos de versiones afectados
- ECOSYSTEM: < 0.7.24+ds-1
Actualiza a 0.7.24+ds-1
ua-parser-js npm
- Intervalos de versiones afectados
- SEMVER: ≥ 0.7.14, < 0.7.24
Actualiza a 0.7.24
node-ua-parser-js Ubuntu:18.04:LTS
- Versiones
- 0.7.14-1
- Intervalos de versiones afectados
- ECOSYSTEM: (−∞, +∞)
Sin corrección publicada
node-ua-parser-js Ubuntu:20.04:LTS
- Versiones
- 0.7.14-1
- Intervalos de versiones afectados
- ECOSYSTEM: (−∞, +∞)
Sin corrección publicada
node-ua-parser-js Ubuntu:22.04:LTS
- Versiones
- 0.7.24+ds-1
- 0.7.24+ds-2
- 0.7.31+ds+~0.7.36-1
- Intervalos de versiones afectados
- ECOSYSTEM: (−∞, +∞)
Sin corrección publicada