CVE-2021-27292
CVE-2021-27292
This page contains facts from public vulnerability sources. Check the original advisory before updating.
ua-parser-js >= 0.7.14, fixed in 0.7.24, uses a regular expression which is vulnerable to denial of service. If an attacker sends a malicious User-Agent header, ua-parser-js will get stuck processing it for an extended period of time.
CVSS 7.5 · High · EPSS 3.4% · Fix available
- Published
- Updated
Affected products and versions
n/a
- Versions
- n/a: Affected
No fix published
node-ua-parser-js Debian:12
- Affected ranges
- ECOSYSTEM: < 0.7.24+ds-1
Update to 0.7.24+ds-1
node-ua-parser-js Debian:13
- Affected ranges
- ECOSYSTEM: < 0.7.24+ds-1
Update to 0.7.24+ds-1
node-ua-parser-js Debian:14
- Affected ranges
- ECOSYSTEM: < 0.7.24+ds-1
Update to 0.7.24+ds-1
ua-parser-js npm
- Affected ranges
- SEMVER: ≥ 0.7.14, < 0.7.24
Update to 0.7.24
node-ua-parser-js Ubuntu:18.04:LTS
- Versions
- 0.7.14-1
- Affected ranges
- ECOSYSTEM: (−∞, +∞)
No fix published
node-ua-parser-js Ubuntu:20.04:LTS
- Versions
- 0.7.14-1
- Affected ranges
- ECOSYSTEM: (−∞, +∞)
No fix published
node-ua-parser-js Ubuntu:22.04:LTS
- Versions
- 0.7.24+ds-1
- 0.7.24+ds-2
- 0.7.31+ds+~0.7.36-1
- Affected ranges
- ECOSYSTEM: (−∞, +∞)
No fix published