p PatchFirst

PatchFirst · Aktuelle Sicherheitslücken

Sicherheitslücken in @auth0/nextjs-auth0

In den letzten 30 Tagen veröffentlichte Sicherheitslücken für @auth0/nextjs-auth0: 0. Davon im KEV-Katalog: 0.

Sicherheitslücken filtern
Filter zurücksetzen

Sicherheitslücken: 7

  1. CVE-2026-40155

    Mittel · CVSS 5.4EPSS 0,21%Korrektur verfügbar

    Auth0 Next.js SDK has Improper Proxy Cache Lookup

    The Auth0 Next.js SDK is a library for implementing user authentication in Next.js applications. In versions 4.12.0 through 4.17.1, simultaneous requests that trigger a nonce retry may cause the proxy cache fetcher to perform improper lookups for the token request results. Users are affected if their project uses both the vulnerable versions and the proxy handler /me/* and /my-org/* with DPoP enabled. This issue has been fixed in version 4.18.0.

    • Auf 4.18.0 aktualisieren
    Veröffentlicht Aktualisiert
  2. CVE-2025-67716

    Mittel · CVSS 5.7EPSS 0,26%Korrektur verfügbar

    Auth0 Next.js SDK has Improper Validation of Query Parameters

    The Auth0 Next.js SDK is a library for implementing user authentication in Next.js applications. Versions 4.9.0 through 4.12.1 contain an input-validation flaw in the returnTo parameter, which could allow attackers to inject unintended OAuth query parameters into the Auth0 authorization request. Successful exploitation may result in tokens being issued with unintended parameters. This issue is fixed in version 4.13.0.

    • Auf 4.13.0 aktualisieren
    Veröffentlicht Aktualisiert
  3. CVE-2025-67490

    Mittel · CVSS 5.4EPSS 0,2%Korrektur verfügbar

    Auth0 Next.js SDK has Improper Request Caching Lookup

    The Auth0 Next.js SDK is a library for implementing user authentication in Next.js applications. When using versions 4.11.0 through 4.11.2 and 4.12.0, simultaneous requests on the same client may result in improper lookups in the TokenRequestCache for the request results. This issue is fixed in versions 4.11.2 and 4.12.1.

    • Auf 4.11.2 aktualisieren
    • Auf 4.12.1 aktualisieren
    Veröffentlicht Aktualisiert
  4. CVE-2025-48947

    Hoch · CVSS 7.7EPSS 0,43%Korrektur verfügbar

    NextJS-Auth0 SDK Vulnerable to CDN Caching of Session Cookies

    The Auth0 Next.js SDK is a library for implementing user authentication in Next.js applications. In Auth0 Next.js SDK versions 4.0.1 through 4.6.0, `__session` cookies set by auth0.middleware may be cached by CDNs due to missing Cache-Control headers. Three preconditions must be met in order for someone to be affected by the vulnerability: Applications using the NextJS-Auth0 SDK, versions between 4.0.1 to 4.6.0, applications using CDN or edge caching that caches responses with the Set-Cookie header, and if the Cache-Control header is not properly set for sensitive responses. Users should upgrade auth0/nextjs-auth0 to v4.6.1 to receive a patch

    • Auf 4.6.1 aktualisieren
    Veröffentlicht Aktualisiert
  5. CVE-2025-46344

    Mittel · CVSS 4.9EPSS 0,44%Korrektur verfügbar

    Auth0 NextJS SDK v4 Missing Session Invalidation

    The Auth0 Next.js SDK is a library for implementing user authentication in Next.js applications. Versions starting from 4.0.1 and prior to 4.5.1, do not invoke `.setExpirationTime` when generating a JWE token for the session. As a result, the JWE does not contain an internal expiration claim. While the session cookie may expire or be cleared, the JWE remains valid. This issue has been patched in version 4.5.1.

    • Auf 4.5.1 aktualisieren
    Veröffentlicht Aktualisiert
  6. CVE-2021-43812

    Mittel · CVSS 6.4EPSS 0,68%Korrektur verfügbar

    Open redirect in nextjs-auth0

    The Auth0 Next.js SDK is a library for implementing user authentication in Next.js applications. Versions before 1.6.2 do not filter out certain returnTo parameter values from the login url, which expose the application to an open redirect vulnerability. Users are advised to upgrade as soon as possible. There are no known workarounds for this issue.

    • Auf 1.6.2 aktualisieren
    Veröffentlicht Aktualisiert
  7. CVE-2021-32702

    Hoch · CVSS 8EPSS 1,4%Korrektur verfügbar

    Reflected XSS from the callback handler's error query parameter

    The Auth0 Next.js SDK is a library for implementing user authentication in Next.js applications. Versions before and including `1.4.1` are vulnerable to reflected XSS. An attacker can execute arbitrary code by providing an XSS payload in the `error` query parameter which is then processed by the callback handler as an error message. You are affected by this vulnerability if you are using `@auth0/nextjs-auth0` version `1.4.1` or lower **unless** you are using custom error handling that does not return the error message in an HTML response. Upgrade to version `1.4.1` to resolve. The fix adds basic HTML escaping to the error message and it shoul

    • Auf 1.4.2 aktualisieren
    Veröffentlicht Aktualisiert

Prüfen Sie Ihren Server

Gleichen Sie Ihren installierten Stack und seine Versionen mit den aktuellen Sicherheitsmeldungen ab.

Prüfen Sie Ihren Server →