p PatchFirst

PatchFirst · Aktuelle Sicherheitslücken

Sicherheitslücken in xz-utils

In den letzten 30 Tagen veröffentlichte Sicherheitslücke für xz-utils: 1. Davon im KEV-Katalog: 0.

Sicherheitslücken filtern
Filter zurücksetzen

Sicherheitslücken: 3

  1. USN-8945-1

    Nicht bewertetKorrektur verfügbar

    xz-utils vulnerability

    It was discovered that XZ Utils incorrectly handled certain memory allocation failures when reinitializing decoders for specific compressed file formats. An attacker could possibly use this issue to trigger an invalid memory write, resulting in a denial of service or arbitrary code execution.

    • Auf 5.1.1alpha+20120614-2ubuntu2.16.04.1+esm3 aktualisieren
    Veröffentlicht Aktualisiert
  2. CVE-2026-34743

    Niedrig · CVSS 1.7EPSS 0,51%Korrektur verfügbar

    XZ Utils: Buffer overflow in lzma_index_append()

    XZ Utils provide a general-purpose data-compression library plus command-line tools. Prior to version 5.8.3, if lzma_index_decoder() was used to decode an Index that contained no Records, the resulting lzma_index was left in a state where where a subsequent lzma_index_append() would allocate too little memory, and a buffer overflow would occur. This issue has been patched in version 5.8.3.

    • Auf 5.1.1alpha+20120614-2ubuntu2.16.04.1+esm2 aktualisieren
    Veröffentlicht Aktualisiert
  3. CVE-2022-1271

    Hoch · CVSS 8.8EPSS 5,55%Korrektur verfügbar

    CVE-2022-1271

    An arbitrary file write vulnerability was found in GNU gzip's zgrep utility. When zgrep is applied on the attacker's chosen file name (for example, a crafted file name), this can overwrite an attacker's content to an arbitrary attacker-selected file. This flaw occurs due to insufficient validation when processing filenames with two or more newlines where selected content and the target file names are embedded in crafted multi-line file names. This flaw allows a remote, low privileged attacker to force zgrep to write arbitrary files on the system.

    • Auf 5.1.1alpha+20120614-2ubuntu2.16.04.1+esm1 aktualisieren
    Veröffentlicht Aktualisiert

Prüfen Sie Ihren Server

Gleichen Sie Ihren installierten Stack und seine Versionen mit den aktuellen Sicherheitsmeldungen ab.

Prüfen Sie Ihren Server →