p PatchFirst

PatchFirst · Aktuelle Sicherheitslücken

Sicherheitslücken in apr

In den letzten 30 Tagen veröffentlichte Sicherheitslücken für apr: 0. Davon im KEV-Katalog: 0.

Sicherheitslücken filtern
Filter zurücksetzen

Sicherheitslücken: 3

  1. CVE-2023-49582

    Mittel · CVSS 5.5EPSS 0,33%Korrektur verfügbar

    Apache Portable Runtime (APR): Unexpected lax shared memory permissions

    Lax permissions set by the Apache Portable Runtime library on Unix platforms would allow local users read access to named shared memory segments, potentially revealing sensitive application data. This issue does not affect non-Unix platforms, or builds with APR_USE_SHMEM_SHMGET=1 (apr.h) Users are recommended to upgrade to APR version 1.7.5, which fixes this issue.

    • Auf 1.5.0-1ubuntu0.1~esm2 aktualisieren
    Veröffentlicht Aktualisiert
  2. CVE-2021-35940

    Hoch · CVSS 7.1EPSS 1,19%Korrektur verfügbar

    Regression of CVE-2017-12613

    An out-of-bounds array read in the apr_time_exp*() functions was fixed in the Apache Portable Runtime 1.6.3 release (CVE-2017-12613). The fix for this issue was not carried forward to the APR 1.7.x branch, and hence version 1.7.0 regressed compared to 1.6.3 and is vulnerable to the same issue.

    • Auf 1.5.0-1ubuntu0.1~esm1 aktualisieren
    Veröffentlicht Aktualisiert
  3. CVE-2017-12613

    Hoch · CVSS 7.1EPSS 1,75%Korrektur verfügbar

    CVE-2017-12613

    When apr_time_exp*() or apr_os_exp_time*() functions are invoked with an invalid month field value in Apache Portable Runtime APR 1.6.2 and prior, out of bounds memory may be accessed in converting this value to an apr_time_exp_t value, potentially revealing the contents of a different static heap value or resulting in program termination, and may represent an information disclosure or denial of service vulnerability to applications which call these APR functions with unvalidated external input.

    • Auf 1.5.0-1ubuntu0.1~esm1 aktualisieren
    Veröffentlicht Aktualisiert

Prüfen Sie Ihren Server

Gleichen Sie Ihren installierten Stack und seine Versionen mit den aktuellen Sicherheitsmeldungen ab.

Prüfen Sie Ihren Server →