CVE-2024-29041
CVE-2024-29041 · Express.js Open Redirect in malformed URLs
Diese Seite enthält Fakten aus öffentlichen Sicherheitsquellen. Lesen Sie vor dem Aktualisieren die Originalmeldung.
Express.js minimalist web framework for node. Versions of Express.js prior to 4.19.0 and all pre-release alpha and beta versions of 5.0 are affected by an open redirect vulnerability using malformed URLs. When a user of Express performs a redirect using a user-provided URL Express performs an encode [using `encodeurl`](https://github.com/pillarjs/encodeurl) on the contents before passing it to the `location` header. This can cause malformed URLs to be evaluated in unexpected ways by common redirect allow list implementations in Express applications, leading to an Open Redirect via bypass of a properly implemented allow list. The main method impacted is `res.location()` but this is also called from within `res.redirect()`. The vulnerability is fixed in 4.19.2 and 5.0.0-beta.3.
CVSS 6.1 · Mittel · EPSS 0,8% · Korrektur verfügbar
- Veröffentlicht
- Aktualisiert
Technologie-Stack: system · node
Betroffene Produkte und Versionen
express
- Softwareversionen
- >=4.14.0, <4.19.0: Betroffen
- >=5.0.0-alpha.1, <5.0.0-beta.3: Betroffen
Keine Korrektur veröffentlicht
node-express Debian:12
- Softwareversionen
- 4.18.2+~4.17.14-1
- 4.18.2+~cs8.34.50-1
- 4.19.2+~cs8.36.21-1
- 4.19.2+~cs8.36.26-1
- 4.21.0+~cs8.36.26-1
- 4.21.0+~cs8.36.26-2
- 4.21.2+~cs8.36.27-1
- 4.21.2+~cs8.36.27-2
- 4.21.2+~cs8.36.27-3
- 5.1.0+~cs12.3.3-1
- 5.2.1+~cs12.3.9-1
- Betroffene Versionsbereiche
- ECOSYSTEM: (−∞, +∞)
Keine Korrektur veröffentlicht
node-express Debian:13
- Betroffene Versionsbereiche
- ECOSYSTEM: < 4.19.2+~cs8.36.21-1
Auf 4.19.2+~cs8.36.21-1 aktualisieren
node-express Debian:14
- Betroffene Versionsbereiche
- ECOSYSTEM: < 4.19.2+~cs8.36.21-1
Auf 4.19.2+~cs8.36.21-1 aktualisieren
express npm
- Betroffene Versionsbereiche
- SEMVER: < 4.19.2
Auf 4.19.2 aktualisieren
express npm
- Betroffene Versionsbereiche
- SEMVER: ≥ 5.0.0-alpha.1, < 5.0.0-beta.3
Auf 5.0.0-beta.3 aktualisieren
node-express Ubuntu:Pro:16.04:LTS
- Softwareversionen
- 4.1.1~dfsg-1
- Betroffene Versionsbereiche
- ECOSYSTEM: < 4.1.1~dfsg-1ubuntu0.16.04.1~esm1
Auf 4.1.1~dfsg-1ubuntu0.16.04.1~esm1 aktualisieren
node-express Ubuntu:Pro:18.04:LTS
- Softwareversionen
- 4.1.1~dfsg-1
- Betroffene Versionsbereiche
- ECOSYSTEM: < 4.1.1~dfsg-1ubuntu0.18.04.1~esm1
Auf 4.1.1~dfsg-1ubuntu0.18.04.1~esm1 aktualisieren
node-express Ubuntu:Pro:20.04:LTS
- Softwareversionen
- 4.17.1-1
- 4.17.1-2
- Betroffene Versionsbereiche
- ECOSYSTEM: < 4.17.1-2ubuntu0.1~esm1
Auf 4.17.1-2ubuntu0.1~esm1 aktualisieren
node-express Ubuntu:Pro:22.04:LTS
- Softwareversionen
- 4.17.1-3
- 4.17.1+~cs4.17.13-1
- 4.17.2+~4.17.13-1
- 4.17.3+~4.17.13-1
- Betroffene Versionsbereiche
- ECOSYSTEM: < 4.17.3+~4.17.13-1ubuntu0.1~esm1
Auf 4.17.3+~4.17.13-1ubuntu0.1~esm1 aktualisieren
Originalquellen
- https://github.com/expressjs/express/security/advisories/GHSA-rv95-896h-c2vc
- https://github.com/koajs/koa/issues/1800
- https://github.com/expressjs/express/pull/5539
- https://github.com/expressjs/express/commit/0867302ddbde0e9463d0564fea5861feb708c2dd
- https://github.com/expressjs/express/commit/0b746953c4bd8e377123527db11f9cd866e39f94
- https://expressjs.com/en/4x/api.html#res.location
- https://nvd.nist.gov/vuln/detail/CVE-2024-29041