CVE-2024-43796
CVE-2024-43796 · express vulnerable to XSS via response.redirect()
Diese Seite enthält Fakten aus öffentlichen Sicherheitsquellen. Lesen Sie vor dem Aktualisieren die Originalmeldung.
Express.js minimalist web framework for node. In express < 4.20.0, passing untrusted user input - even after sanitizing it - to response.redirect() may execute untrusted code. This issue is patched in express 4.20.0.
CVSS 5.0 · Mittel · EPSS 0,5% · Korrektur verfügbar
- Veröffentlicht
- Aktualisiert
Technologie-Stack: system · node
Betroffene Produkte und Versionen
express
- Softwareversionen
- < 4.20.0: Betroffen
- >= 5.0.0-alpha.1, < 5.0.0: Betroffen
Keine Korrektur veröffentlicht
node-express Debian:12
- Softwareversionen
- 4.18.2+~4.17.14-1
- 4.18.2+~cs8.34.50-1
- 4.19.2+~cs8.36.21-1
- 4.19.2+~cs8.36.26-1
- 4.21.0+~cs8.36.26-1
- 4.21.0+~cs8.36.26-2
- 4.21.2+~cs8.36.27-1
- 4.21.2+~cs8.36.27-2
- 4.21.2+~cs8.36.27-3
- 5.1.0+~cs12.3.3-1
- 5.2.1+~cs12.3.9-1
- Betroffene Versionsbereiche
- ECOSYSTEM: (−∞, +∞)
Keine Korrektur veröffentlicht
node-express Debian:13
- Betroffene Versionsbereiche
- ECOSYSTEM: < 4.21.0+~cs8.36.26-1
Auf 4.21.0+~cs8.36.26-1 aktualisieren
node-express Debian:14
- Betroffene Versionsbereiche
- ECOSYSTEM: < 4.21.0+~cs8.36.26-1
Auf 4.21.0+~cs8.36.26-1 aktualisieren
express npm
- Betroffene Versionsbereiche
- SEMVER: < 4.20.0
Auf 4.20.0 aktualisieren
express npm
- Betroffene Versionsbereiche
- SEMVER: ≥ 5.0.0-alpha.1, < 5.0.0
Auf 5.0.0 aktualisieren
node-express Ubuntu:Pro:16.04:LTS
- Softwareversionen
- 4.1.1~dfsg-1
- Betroffene Versionsbereiche
- ECOSYSTEM: < 4.1.1~dfsg-1ubuntu0.16.04.1~esm1
Auf 4.1.1~dfsg-1ubuntu0.16.04.1~esm1 aktualisieren
node-express Ubuntu:Pro:18.04:LTS
- Softwareversionen
- 4.1.1~dfsg-1
- Betroffene Versionsbereiche
- ECOSYSTEM: < 4.1.1~dfsg-1ubuntu0.18.04.1~esm1
Auf 4.1.1~dfsg-1ubuntu0.18.04.1~esm1 aktualisieren
node-express Ubuntu:Pro:20.04:LTS
- Softwareversionen
- 4.17.1-1
- 4.17.1-2
- Betroffene Versionsbereiche
- ECOSYSTEM: < 4.17.1-2ubuntu0.1~esm1
Auf 4.17.1-2ubuntu0.1~esm1 aktualisieren
node-express Ubuntu:Pro:22.04:LTS
- Softwareversionen
- 4.17.1-3
- 4.17.1+~cs4.17.13-1
- 4.17.2+~4.17.13-1
- 4.17.3+~4.17.13-1
- Betroffene Versionsbereiche
- ECOSYSTEM: < 4.17.3+~4.17.13-1ubuntu0.1~esm1
Auf 4.17.3+~4.17.13-1ubuntu0.1~esm1 aktualisieren
node-express Ubuntu:Pro:24.04:LTS
- Softwareversionen
- 4.18.2+~cs8.34.50-1
- 4.19.2+~cs8.36.21-1
- Betroffene Versionsbereiche
- ECOSYSTEM: < 4.19.2+~cs8.36.21-1ubuntu0.1~esm1
Auf 4.19.2+~cs8.36.21-1ubuntu0.1~esm1 aktualisieren