p PatchFirst

PatchFirst · Aktuelle Sicherheitslücken

Sicherheitslücken in setasign/fpdi

In den letzten 30 Tagen veröffentlichte Sicherheitslücken für setasign/fpdi: 0. Davon im KEV-Katalog: 0.

Sicherheitslücken filtern
Filter zurücksetzen

Sicherheitslücken: 2

  1. CVE-2026-45802

    Mittel · CVSS 6EPSS 0,26%Korrektur verfügbar

    FPDI: Memory Exhaustion and Endless Loop in FPDI leads to Denial of Service

    FPDI is a collection of PHP classes that facilitate reading pages from existing PDF documents and using them as templates in FPDF. Prior to version 2.6.7, an attacker can upload a small, malicious PDF file that will cause the server-side script to crash due to memory exhaustion or a script time-out. Repeated attacks can lead to sustained service unavailability. This issue has been patched in version 2.6.7.

    • Auf 2.6.7 aktualisieren
    Veröffentlicht Aktualisiert
  2. CVE-2025-54869

    Mittel · CVSS 6EPSS 0,33%Korrektur verfügbar

    FPDI is Vulnerable to Memory Exhaustion (OOM) through its PDF Parser

    FPDI is a collection of PHP classes that facilitate reading pages from existing PDF documents and using them as templates in FPDF. In versions 2.6.2 and below, any application that uses FPDI to process user-supplied PDF files is at risk, causing a Denial of Service (DoS) vulnerability. An attacker can upload a small, malicious PDF file that will cause the server-side script to crash due to memory exhaustion. Repeated attacks can lead to sustained service unavailability. This issue is fixed in version 2.6.3.

    • Auf 2.6.4 aktualisieren
    Veröffentlicht Aktualisiert

Prüfen Sie Ihren Server

Gleichen Sie Ihren installierten Stack und seine Versionen mit den aktuellen Sicherheitsmeldungen ab.

Prüfen Sie Ihren Server →