p PatchFirst

CVE-2025-58064

CVE-2025-58064 · CKEditor is susceptible to Cross-Site Scripting (XSS) through its clipboard package

Diese Seite enthält Fakten aus öffentlichen Sicherheitsquellen. Lesen Sie vor dem Aktualisieren die Originalmeldung.

CKEditor 5 is a modern JavaScript rich-text editor with an MVC architecture. ckeditor5 and ckeditor5-clipboard versions 46.0.0 through 46.0.2 and 44.2.0 through 45.2.1 contain a Cross-Site Scripting (XSS) vulnerability. Ability to exploit could be triggered by a specific user action (leading to unauthorized JavaScript code execution) if the attacker managed to insert a malicious content into the editor, which might happen with a very specific editor configuration. This vulnerability affects installations where the editor configuration meets one of the following criteria: the HTML embed plugin is enabled, or there is a custom plugin introducing an editable element where view RawElement is enabled. This issue is fixed in versions 45.2.2 and 46.0.3 of both ckeditor5 and ckeditor5-clipboard.

CVSS 2.3 · Niedrig · EPSS 0,4% · Korrektur verfügbar

Veröffentlicht
Aktualisiert

Technologie-Stack: node

Betroffene Produkte und Versionen

  • ckeditor5

    Softwareversionen
    • >= 46.0.0, < 46.0.3: Betroffen
    • >= 44.2.0, < 45.2.2: Betroffen

    Keine Korrektur veröffentlicht

  • ckeditor5 npm

    Betroffene Versionsbereiche
    • SEMVER: ≥ 46.0.0, < 46.0.3

    Auf 46.0.3 aktualisieren

  • @ckeditor/ckeditor5-clipboard npm

    Betroffene Versionsbereiche
    • SEMVER: ≥ 44.2.0, < 45.2.2

    Auf 45.2.2 aktualisieren

  • ckeditor5 npm

    Betroffene Versionsbereiche
    • SEMVER: ≥ 44.2.0, < 45.2.2

    Auf 45.2.2 aktualisieren

  • @ckeditor/ckeditor5-clipboard npm

    Betroffene Versionsbereiche
    • SEMVER: ≥ 46.0.0, < 46.0.3

    Auf 46.0.3 aktualisieren

Originalquellen

Prüfen Sie Ihren Server →