p PatchFirst

CVE-2025-58064

CVE-2025-58064 · CKEditor is susceptible to Cross-Site Scripting (XSS) through its clipboard package

Esta página presenta datos de fuentes públicas de vulnerabilidades. Consulta el aviso original antes de actualizar.

CKEditor 5 is a modern JavaScript rich-text editor with an MVC architecture. ckeditor5 and ckeditor5-clipboard versions 46.0.0 through 46.0.2 and 44.2.0 through 45.2.1 contain a Cross-Site Scripting (XSS) vulnerability. Ability to exploit could be triggered by a specific user action (leading to unauthorized JavaScript code execution) if the attacker managed to insert a malicious content into the editor, which might happen with a very specific editor configuration. This vulnerability affects installations where the editor configuration meets one of the following criteria: the HTML embed plugin is enabled, or there is a custom plugin introducing an editable element where view RawElement is enabled. This issue is fixed in versions 45.2.2 and 46.0.3 of both ckeditor5 and ckeditor5-clipboard.

CVSS 2.3 · Baja · EPSS 0,4% · Corrección disponible

Publicación
Actualización

Pila tecnológica: node

Productos y versiones afectados

  • ckeditor5

    Versiones
    • >= 46.0.0, < 46.0.3: Afectada
    • >= 44.2.0, < 45.2.2: Afectada

    Sin corrección publicada

  • ckeditor5 npm

    Intervalos de versiones afectados
    • SEMVER: ≥ 46.0.0, < 46.0.3

    Actualiza a 46.0.3

  • @ckeditor/ckeditor5-clipboard npm

    Intervalos de versiones afectados
    • SEMVER: ≥ 44.2.0, < 45.2.2

    Actualiza a 45.2.2

  • ckeditor5 npm

    Intervalos de versiones afectados
    • SEMVER: ≥ 44.2.0, < 45.2.2

    Actualiza a 45.2.2

  • @ckeditor/ckeditor5-clipboard npm

    Intervalos de versiones afectados
    • SEMVER: ≥ 46.0.0, < 46.0.3

    Actualiza a 46.0.3

Fuentes originales

Comprueba tu servidor →