p PatchFirst

PatchFirst · Aktuelle Sicherheitslücken

Sicherheitslücken in @aws/lsp-codewhisperer

In den letzten 30 Tagen veröffentlichte Sicherheitslücken für @aws/lsp-codewhisperer: 0. Davon im KEV-Katalog: 0.

Sicherheitslücken filtern
Filter zurücksetzen

Sicherheitslücken: 2

  1. CVE-2026-12958

    Hoch · CVSS 8.5EPSS 0,19%Korrektur verfügbar

    Arbitrary file write in Language Servers for AWS

    Missing symlink validation in Language Servers for AWS may allow an arbitrary file write outside of the workspace trust boundary. This may occur when a local user opens a workspace with a maliciously crafted symlink that resolves to a file path outside the workspace trust boundary. To remediate this issue, users should upgrade to version 1.69.0 or higher.

    • Auf 0.0.117 aktualisieren
    Veröffentlicht Aktualisiert
  2. CVE-2026-12957

    Hoch · CVSS 8.5EPSS 0,23%Korrektur verfügbar

    Arbitrary Code Execution in Language Servers for AWS

    Improper trust boundary enforcement in Language Servers for AWS before version 1.65.0 on all supported platforms may allow a for arbitrary code execution. If a local user opens a maliciously crafted workspace, any commands within the project configuration files may be automatically executed. This issue requires the user to trust the workspace when prompted. To remediate this issue, users should upgrade to Language Servers for AWS version 1.65.0 or higher.

    • Auf 0.0.113 aktualisieren
    Veröffentlicht Aktualisiert

Prüfen Sie Ihren Server

Gleichen Sie Ihren installierten Stack und seine Versionen mit den aktuellen Sicherheitsmeldungen ab.

Prüfen Sie Ihren Server →