p PatchFirst

CVE-2026-23490

CVE-2026-23490 · pyasn1 has a DoS vulnerability in decoder

Diese Seite enthält Fakten aus öffentlichen Sicherheitsquellen. Lesen Sie vor dem Aktualisieren die Originalmeldung.

Diese Seite zeigt ausgewählte Angaben aus den Quellen. Die vollständige Beschreibung und betroffene Versionen finden Sie in den verlinkten Sicherheitshinweisen.

pyasn1 is a generic ASN.1 library for Python. Prior to 0.6.2, a Denial-of-Service issue has been found that leads to memory exhaustion from malformed RELATIVE-OID with excessive continuation octets. This vulnerability is fixed in 0.6.2.

CVSS 7.5 · Hoch · EPSS 0,8% · Korrektur verfügbar

Veröffentlicht
Aktualisiert

Technologie-Stack: system · python

Betroffene Produkte und Versionen

  • pyasn1

    Softwareversionen
    • < 0.6.2: Betroffen

    Keine Korrektur veröffentlicht

  • pyasn1 Debian:12

    Softwareversionen
    • 0.4.8-3
    Betroffene Versionsbereiche
    • ECOSYSTEM: < 0.4.8-3+deb12u1

    Auf 0.4.8-3+deb12u1 aktualisieren

  • pyasn1 Debian:13

    Softwareversionen
    • 0.6.1-1
    Betroffene Versionsbereiche
    • ECOSYSTEM: < 0.6.1-1+deb13u1

    Auf 0.6.1-1+deb13u1 aktualisieren

  • pyasn1 Debian:14

    Softwareversionen
    • 0.6.1-1
    • 0.6.2-1~bpo13+1
    Betroffene Versionsbereiche
    • ECOSYSTEM: < 0.6.2-1

    Auf 0.6.2-1 aktualisieren

  • pyasn1 PyPI

    Softwareversionen
    • 0.6.1
    Betroffene Versionsbereiche
    • ECOSYSTEM: ≥ 0.6.1, < 0.6.2

    Auf 0.6.2 aktualisieren

  • pyasn1 Ubuntu:Pro:14.04:LTS

    Softwareversionen
    • 0.1.4-0ubuntu1
    • 0.1.7-1ubuntu1
    • 0.1.7-1ubuntu2
    • 0.1.7-1ubuntu2.1
    Betroffene Versionsbereiche
    • ECOSYSTEM: < 0.1.7-1ubuntu2.1+esm1

    Auf 0.1.7-1ubuntu2.1+esm1 aktualisieren

  • pyasn1 Ubuntu:Pro:16.04:LTS

    Softwareversionen
    • 0.1.8-2
    • 0.1.9-1
    Betroffene Versionsbereiche
    • ECOSYSTEM: < 0.1.9-1ubuntu0.1~esm1

    Auf 0.1.9-1ubuntu0.1~esm1 aktualisieren

  • pyasn1 Ubuntu:Pro:18.04:LTS

    Softwareversionen
    • 0.1.9-2
    • 0.4.2-3
    Betroffene Versionsbereiche
    • ECOSYSTEM: < 0.4.2-3ubuntu0.18.04.1~esm1

    Auf 0.4.2-3ubuntu0.18.04.1~esm1 aktualisieren

  • pyasn1 Ubuntu:Pro:20.04:LTS

    Softwareversionen
    • 0.4.2-3
    • 0.4.2-3build1
    Betroffene Versionsbereiche
    • ECOSYSTEM: < 0.4.2-3ubuntu0.20.04.1~esm1

    Auf 0.4.2-3ubuntu0.20.04.1~esm1 aktualisieren

  • pyasn1 Ubuntu:22.04:LTS

    Softwareversionen
    • 0.4.8-1
    Betroffene Versionsbereiche
    • ECOSYSTEM: < 0.4.8-1ubuntu0.1

    Auf 0.4.8-1ubuntu0.1 aktualisieren

  • pyasn1 Ubuntu:24.04:LTS

    Softwareversionen
    • 0.4.8-4
    Betroffene Versionsbereiche
    • ECOSYSTEM: < 0.4.8-4ubuntu0.1

    Auf 0.4.8-4ubuntu0.1 aktualisieren

  • pyasn1 Ubuntu:25.10

    Softwareversionen
    • 0.6.1-1
    Betroffene Versionsbereiche
    • ECOSYSTEM: < 0.6.1-1ubuntu0.1

    Auf 0.6.1-1ubuntu0.1 aktualisieren

Originalquellen

Prüfen Sie Ihren Server →