CVE-2026-23490
CVE-2026-23490 · pyasn1 has a DoS vulnerability in decoder
This page contains facts from public vulnerability sources. Check the original advisory before updating.
This page shows selected source facts. See the linked advisories for the complete description and affected versions.
pyasn1 is a generic ASN.1 library for Python. Prior to 0.6.2, a Denial-of-Service issue has been found that leads to memory exhaustion from malformed RELATIVE-OID with excessive continuation octets. This vulnerability is fixed in 0.6.2.
CVSS 7.5 · High · EPSS 0.8% · Fix available
- Published
- Updated
Affected products and versions
pyasn1
- Versions
- < 0.6.2: Affected
No fix published
pyasn1 Debian:12
- Versions
- 0.4.8-3
- Affected ranges
- ECOSYSTEM: < 0.4.8-3+deb12u1
Update to 0.4.8-3+deb12u1
pyasn1 Debian:13
- Versions
- 0.6.1-1
- Affected ranges
- ECOSYSTEM: < 0.6.1-1+deb13u1
Update to 0.6.1-1+deb13u1
pyasn1 Debian:14
- Versions
- 0.6.1-1
- 0.6.2-1~bpo13+1
- Affected ranges
- ECOSYSTEM: < 0.6.2-1
Update to 0.6.2-1
pyasn1 PyPI
- Versions
- 0.6.1
- Affected ranges
- ECOSYSTEM: ≥ 0.6.1, < 0.6.2
Update to 0.6.2
pyasn1 Ubuntu:Pro:14.04:LTS
- Versions
- 0.1.4-0ubuntu1
- 0.1.7-1ubuntu1
- 0.1.7-1ubuntu2
- 0.1.7-1ubuntu2.1
- Affected ranges
- ECOSYSTEM: < 0.1.7-1ubuntu2.1+esm1
Update to 0.1.7-1ubuntu2.1+esm1
pyasn1 Ubuntu:Pro:16.04:LTS
- Versions
- 0.1.8-2
- 0.1.9-1
- Affected ranges
- ECOSYSTEM: < 0.1.9-1ubuntu0.1~esm1
Update to 0.1.9-1ubuntu0.1~esm1
pyasn1 Ubuntu:Pro:18.04:LTS
- Versions
- 0.1.9-2
- 0.4.2-3
- Affected ranges
- ECOSYSTEM: < 0.4.2-3ubuntu0.18.04.1~esm1
Update to 0.4.2-3ubuntu0.18.04.1~esm1
pyasn1 Ubuntu:Pro:20.04:LTS
- Versions
- 0.4.2-3
- 0.4.2-3build1
- Affected ranges
- ECOSYSTEM: < 0.4.2-3ubuntu0.20.04.1~esm1
Update to 0.4.2-3ubuntu0.20.04.1~esm1
pyasn1 Ubuntu:22.04:LTS
- Versions
- 0.4.8-1
- Affected ranges
- ECOSYSTEM: < 0.4.8-1ubuntu0.1
Update to 0.4.8-1ubuntu0.1
pyasn1 Ubuntu:24.04:LTS
- Versions
- 0.4.8-4
- Affected ranges
- ECOSYSTEM: < 0.4.8-4ubuntu0.1
Update to 0.4.8-4ubuntu0.1
pyasn1 Ubuntu:25.10
- Versions
- 0.6.1-1
- Affected ranges
- ECOSYSTEM: < 0.6.1-1ubuntu0.1
Update to 0.6.1-1ubuntu0.1
Original sources
- https://github.com/pyasn1/pyasn1/security/advisories/GHSA-63vm-454h-vhhq
- https://github.com/pyasn1/pyasn1/commit/3908f144229eed4df24bd569d16e5991ace44970
- https://github.com/pyasn1/pyasn1/releases/tag/v0.6.2
- https://lists.debian.org/debian-lts-announce/2026/02/msg00002.html
- https://access.redhat.com/security/cve/CVE-2026-23490
- https://bugzilla.redhat.com/show_bug.cgi?id=2430472
- https://security.access.redhat.com/data/csaf/v2/vex/2026/cve-2026-23490.json
- https://access.redhat.com/errata/RHSA-2026:4148
- https://access.redhat.com/errata/RHSA-2026:2758
- https://access.redhat.com/errata/RHSA-2026:3959
- https://access.redhat.com/errata/RHSA-2026:13512
- https://access.redhat.com/errata/RHSA-2026:54757
- https://access.redhat.com/errata/RHSA-2026:28042
- https://access.redhat.com/errata/RHSA-2026:3958
- https://access.redhat.com/errata/RHSA-2026:13508
- https://access.redhat.com/errata/RHSA-2026:17595
- https://access.redhat.com/errata/RHSA-2026:17446
- https://access.redhat.com/errata/RHSA-2026:2309
- https://access.redhat.com/errata/RHSA-2026:4138
- https://access.redhat.com/errata/RHSA-2026:1905
- https://access.redhat.com/errata/RHSA-2026:3354
- https://access.redhat.com/errata/RHSA-2026:1906
- https://access.redhat.com/errata/RHSA-2026:4146
- https://nvd.nist.gov/vuln/detail/CVE-2026-23490