p PatchFirst

PatchFirst · Aktuelle Sicherheitslücken

Sicherheitslücken in pyasn1

In den letzten 30 Tagen veröffentlichte Sicherheitslücken für pyasn1: 0. Davon im KEV-Katalog: 0.

Sicherheitslücken filtern
Filter zurücksetzen

Sicherheitslücken: 2

  1. CVE-2026-30922

    Hoch · CVSS 7.5EPSS 0,82%Korrektur verfügbar

    pyasn1 Vulnerable to Denial of Service via Unbounded Recursion

    pyasn1 is a generic ASN.1 library for Python. Prior to 0.6.3, the `pyasn1` library is vulnerable to a Denial of Service (DoS) attack caused by uncontrolled recursion when decoding ASN.1 data with deeply nested structures. An attacker can supply a crafted payload containing thousands of nested `SEQUENCE` (`0x30`) or `SET` (`0x31`) tags with "Indefinite Length" (`0x80`) markers. This forces the decoder to recursively call itself until the Python interpreter crashes with a `RecursionError` or consumes all available memory (OOM), crashing the host application. This is a distinct vulnerability from CVE-2026-23490 (which addressed integer overflows

    • Auf 0.6.1-1ubuntu0.2 aktualisieren
    Veröffentlicht Aktualisiert
  2. CVE-2026-23490

    Hoch · CVSS 7.5EPSS 0,76%Korrektur verfügbar

    pyasn1 has a DoS vulnerability in decoder

    pyasn1 is a generic ASN.1 library for Python. Prior to 0.6.2, a Denial-of-Service issue has been found that leads to memory exhaustion from malformed RELATIVE-OID with excessive continuation octets. This vulnerability is fixed in 0.6.2.

    • Auf 0.6.1-1ubuntu0.1 aktualisieren
    Veröffentlicht Aktualisiert

Prüfen Sie Ihren Server

Gleichen Sie Ihren installierten Stack und seine Versionen mit den aktuellen Sicherheitsmeldungen ab.

Prüfen Sie Ihren Server →