p PatchFirst

PatchFirst · Aktuelle Sicherheitslücken

Sicherheitslücken in @fastify/middie

In den letzten 30 Tagen veröffentlichte Sicherheitslücken für @fastify/middie: 0. Davon im KEV-Katalog: 0.

Sicherheitslücken filtern
Filter zurücksetzen

Sicherheitslücken: 4

  1. CVE-2026-33804

    Hoch · CVSS 7.4EPSS 0,28%Korrektur verfügbar

    @fastify/middie vulnerable to middleware bypass via deprecated ignoreDuplicateSlashes option

    @fastify/middie versions 9.3.1 and earlier are vulnerable to middleware bypass when the deprecated Fastify ignoreDuplicateSlashes option is enabled. The middleware path matching logic does not account for duplicate slash normalization performed by Fastify's router, allowing requests with duplicate slashes to bypass middleware authentication and authorization checks. This only affects applications using the deprecated ignoreDuplicateSlashes option. Upgrade to @fastify/middie 9.3.2 to fix this issue. There are no workarounds other than disabling the ignoreDuplicateSlashes option.

    • Auf 9.3.2 aktualisieren
    Veröffentlicht Aktualisiert
  2. CVE-2026-6270

    Kritisch · CVSS 9.1EPSS 0,5%Korrektur verfügbar

    @fastify/middie vulnerable to middleware authentication bypass in child plugin scopes

    @fastify/middie versions 9.3.1 and earlier do not register inherited middleware directly on child plugin engine instances. When a Fastify application registers authentication middleware in a parent scope and then registers child plugins with @fastify/middie, the child scope does not inherit the parent middleware. This allows unauthenticated requests to reach routes defined in child plugin scopes, bypassing authentication and authorization checks. Upgrade to @fastify/middie 9.3.2 to fix this issue. There are no workarounds.

    • Auf 9.3.2 aktualisieren
    Veröffentlicht Aktualisiert
  3. CVE-2026-2880

    Hoch · CVSS 8.2EPSS 0,43%Korrektur verfügbar

    @fastify/middie has an improper path normalization vulnerability

    A vulnerability in @fastify/middie versions < 9.2.0 can result in authentication/authorization bypass when using path-scoped middleware (for example, app.use('/secret', auth)). When Fastify router normalization options are enabled (such as ignoreDuplicateSlashes, useSemicolonDelimiter, and related trailing-slash behavior), crafted request paths may bypass middleware checks while still being routed to protected handlers.

    • Auf 9.2.0 aktualisieren
    Veröffentlicht Aktualisiert
  4. CVE-2026-22031

    Hoch · CVSS 8.4EPSS 0,53%Korrektur verfügbar

    Fastify Middie Middleware Path Bypass

    @fastify/middie is the plugin that adds middleware support on steroids to Fastify. A security vulnerability exists in @fastify/middie prior to version 9.1.0 where middleware registered with a specific path prefix can be bypassed using URL-encoded characters (e.g., `/%61dmin` instead of `/admin`). While the middleware engine fails to match the encoded path and skips execution, the underlying Fastify router correctly decodes the path and matches the route handler, allowing attackers to access protected endpoints without the middleware constraints. Version 9.1.0 fixes the issue.

    • Auf 9.1.0 aktualisieren
    Veröffentlicht Aktualisiert

Prüfen Sie Ihren Server

Gleichen Sie Ihren installierten Stack und seine Versionen mit den aktuellen Sicherheitsmeldungen ab.

Prüfen Sie Ihren Server →