p PatchFirst

PatchFirst · Aktuelle Sicherheitslücken

Sicherheitslücken in flask

In den letzten 30 Tagen veröffentlichte Sicherheitslücken für flask: 0. Davon im KEV-Katalog: 0.

Sicherheitslücken filtern
Filter zurücksetzen

Sicherheitslücken: 4

  1. CVE-2026-27205

    Niedrig · CVSS 2.3EPSS 0,4%Keine Korrektur veröffentlicht

    Flask session does not add `Vary: Cookie` header when accessed in some ways

    Flask is a web server gateway interface (WSGI) web application framework. In versions 3.1.2 and below, when the session object is accessed, Flask should set the Vary: Cookie header., resulting in a Use of Cache Containing Sensitive Information vulnerability. The logic instructs caches not to cache the response, as it may contain information specific to a logged in user. This is handled in most cases, but some forms of access such as the Python in operator were overlooked. The severity and risk depend on the application being hosted behind a caching proxy that doesn't ignore responses with cookies, not setting a Cache-Control header to mark pa

    Veröffentlicht Aktualisiert
  2. CVE-2023-30861

    Hoch · CVSS 7.5EPSS 1,25%Öffentlicher ExploitKorrektur verfügbar

    Flask vulnerable to possible disclosure of permanent session cookie due to missing Vary: Cookie header

    Flask is a lightweight WSGI web application framework. When all of the following conditions are met, a response containing data intended for one client may be cached and subsequently sent by the proxy to other clients. If the proxy also caches `Set-Cookie` headers, it may send one client's `session` cookie to other clients. The severity depends on the application's use of the session and the proxy's behavior regarding cookies. The risk depends on all these conditions being met. 1. The application must be hosted behind a caching proxy that does not strip cookies or ignore responses with cookies. 2. The application sets `session.permanent = Tr

    • Auf 2.2.2-3 aktualisieren
    Veröffentlicht Aktualisiert
  3. CVE-2019-1010083

    Hoch · CVSS 8.7EPSS 1,83%Korrektur verfügbar

    CVE-2019-1010083

    The Pallets Project Flask before 1.0 is affected by: unexpected memory usage. The impact is: denial of service. The attack vector is: crafted encoded JSON data. The fixed version is: 1. NOTE: this may overlap CVE-2018-1000656.

    • Auf 1.0.2-1 aktualisieren
    Veröffentlicht Aktualisiert
  4. CVE-2018-1000656

    Hoch · CVSS 8.7EPSS 3,85%Korrektur verfügbar

    CVE-2018-1000656

    The Pallets Project flask version Before 0.12.3 contains a CWE-20: Improper Input Validation vulnerability in flask that can result in Large amount of memory usage possibly leading to denial of service. This attack appear to be exploitable via Attacker provides JSON data in incorrect encoding. This vulnerability appears to have been fixed in 0.12.3. NOTE: this may overlap CVE-2019-1010083.

    • Auf 1.0.2-1 aktualisieren
    Veröffentlicht Aktualisiert

Prüfen Sie Ihren Server

Gleichen Sie Ihren installierten Stack und seine Versionen mit den aktuellen Sicherheitsmeldungen ab.

Prüfen Sie Ihren Server →