p PatchFirst

PatchFirst · Aktuelle Sicherheitslücken

Sicherheitslücken in strongswan · Seite 2

In den letzten 30 Tagen veröffentlichte Sicherheitslücken für strongswan: 0. Davon im KEV-Katalog: 0.

Sicherheitslücken filtern
Filter zurücksetzen

Sicherheitslücken: 59

  1. CVE-2022-4967

    Hoch · CVSS 7.7EPSS 0,47%Korrektur verfügbar

    CVE-2022-4967

    strongSwan versions 5.9.2 through 5.9.5 are affected by authorization bypass through improper validation of certificate with host mismatch (CWE-297). When certificates are used to authenticate clients in TLS-based EAP methods, the IKE or EAP identity supplied by a client is not enforced to be contained in the client's certificate. So clients can authenticate with any trusted certificate and claim an arbitrary IKE/EAP identity as their own. This is problematic if the identity is used to make policy decisions. A fix was released in strongSwan version 5.9.6 in August 2022 (e4b4aabc4996fc61c37deab7858d07bc4d220136).

    • Auf 5.9.6-1 aktualisieren
    Veröffentlicht Aktualisiert
  2. CVE-2023-41913

    Kritisch · CVSS 9.8EPSS 2,31%Korrektur verfügbar

    CVE-2023-41913

    strongSwan before 5.9.12 has a buffer overflow and possible unauthenticated remote code execution via a DH public value that exceeds the internal buffer in charon-tkm's DH proxy. The earliest affected version is 5.3.0. An attack can occur via a crafted IKE_SA_INIT message.

    • Auf 5.9.8-5+deb12u1 aktualisieren
    Veröffentlicht Aktualisiert
  3. CVE-2023-26463

    Kritisch · CVSS 9.8EPSS 2,28%Korrektur verfügbar

    CVE-2023-26463

    strongSwan 5.9.8 and 5.9.9 potentially allows remote code execution because it uses a variable named "public" for two different purposes within the same function. There is initially incorrect access control, later followed by an expired pointer dereference. One attack vector is sending an untrusted client certificate during EAP-TLS. A server is affected only if it loads plugins that implement TLS-based EAP methods (EAP-TLS, EAP-TTLS, EAP-PEAP, or EAP-TNC). This is fixed in 5.9.10.

    • Auf 5.9.8-4 aktualisieren
    Veröffentlicht Aktualisiert
  4. CVE-2022-40617

    Hoch · CVSS 7.5EPSS 1,98%Korrektur verfügbar

    CVE-2022-40617

    strongSwan before 5.9.8 allows remote attackers to cause a denial of service in the revocation plugin by sending a crafted end-entity (and intermediate CA) certificate that contains a CRL/OCSP URL that points to a server (under the attacker's control) that doesn't properly respond but (for example) just does nothing after the initial TCP handshake, or sends an excessive amount of application data.

    • Auf 5.9.8-1 aktualisieren
    Veröffentlicht Aktualisiert
  5. CVE-2021-45079

    Kritisch · CVSS 9.1EPSS 2,78%Korrektur verfügbar

    CVE-2021-45079

    In strongSwan before 5.9.5, a malicious responder can send an EAP-Success message too early without actually authenticating the client and (in the case of EAP methods with mutual authentication and EAP-only authentication for IKEv2) even without server authentication.

    • Auf 5.9.5-1 aktualisieren
    Veröffentlicht Aktualisiert
  6. CVE-2021-41990

    Hoch · CVSS 7.5EPSS 6,97%Korrektur verfügbar

    CVE-2021-41990

    The gmp plugin in strongSwan before 5.9.4 has a remote integer overflow via a crafted certificate with an RSASSA-PSS signature. For example, this can be triggered by an unrelated self-signed CA certificate sent by an initiator. Remote code execution cannot occur.

    • Auf 5.9.4-1 aktualisieren
    Veröffentlicht Aktualisiert
  7. CVE-2021-41991

    Hoch · CVSS 7.5EPSS 5,3%Korrektur verfügbar

    CVE-2021-41991

    The in-memory certificate cache in strongSwan before 5.9.4 has a remote integer overflow upon receiving many requests with different certificates to fill the cache and later trigger the replacement of cache entries. The code attempts to select a less-often-used cache entry by means of a random number generator, but this is not done correctly. Remote code execution might be a slight possibility.

    • Auf 5.9.4-1 aktualisieren
    Veröffentlicht Aktualisiert
  8. CVE-2019-10155

    Niedrig · CVSS 3.1EPSS 0,5%Korrektur verfügbar

    CVE-2019-10155

    The Libreswan Project has found a vulnerability in the processing of IKEv1 informational exchange packets which are encrypted and integrity protected using the established IKE SA encryption and integrity keys, but as a receiver, the integrity check value was not verified. This issue affects versions before 3.29.

    • Auf 5.1.0-1 aktualisieren
    Veröffentlicht Aktualisiert
  9. CVE-2018-16152

    Hoch · CVSS 7.5EPSS 1,89%Korrektur verfügbar

    CVE-2018-16152

    In verify_emsa_pkcs1_signature() in gmp_rsa_public_key.c in the gmp plugin in strongSwan 4.x and 5.x before 5.7.0, the RSA implementation based on GMP does not reject excess data in the digestAlgorithm.parameters field during PKCS#1 v1.5 signature verification. Consequently, a remote attacker can forge signatures when small public exponents are being used, which could lead to impersonation when only an RSA signature is used for IKEv2 authentication. This is a variant of CVE-2006-4790 and CVE-2014-1568.

    • Auf 5.7.0-1 aktualisieren
    Veröffentlicht Aktualisiert
  10. CVE-2018-16151

    Hoch · CVSS 7.5EPSS 1,89%Korrektur verfügbar

    CVE-2018-16151

    In verify_emsa_pkcs1_signature() in gmp_rsa_public_key.c in the gmp plugin in strongSwan 4.x and 5.x before 5.7.0, the RSA implementation based on GMP does not reject excess data after the encoded algorithm OID during PKCS#1 v1.5 signature verification. Similar to the flaw in the same version of strongSwan regarding digestAlgorithm.parameters, a remote attacker can forge signatures when small public exponents are being used, which could lead to impersonation when only an RSA signature is used for IKEv2 authentication.

    • Auf 5.7.0-1 aktualisieren
    Veröffentlicht Aktualisiert
  11. CVE-2018-5389

    Mittel · CVSS 5.9EPSS 3,06%Keine Korrektur veröffentlicht

    CVE-2018-5389

    The Internet Key Exchange v1 main mode is vulnerable to offline dictionary or brute force attacks. Reusing a key pair across different versions and modes of IKE could lead to cross-protocol authentication bypasses. It is well known, that the aggressive mode of IKEv1 PSK is vulnerable to offline dictionary or brute force attacks. For the main mode, however, only an online attack against PSK authentication was thought to be feasible. This vulnerability could allow an attacker to recover a weak Pre-Shared Key or enable the impersonation of a victim host or network.

    Veröffentlicht Aktualisiert

Prüfen Sie Ihren Server

Gleichen Sie Ihren installierten Stack und seine Versionen mit den aktuellen Sicherheitsmeldungen ab.

Prüfen Sie Ihren Server →