p PatchFirst

CVE-2023-26463

CVE-2023-26463

Diese Seite enthält Fakten aus öffentlichen Sicherheitsquellen. Lesen Sie vor dem Aktualisieren die Originalmeldung.

strongSwan 5.9.8 and 5.9.9 potentially allows remote code execution because it uses a variable named "public" for two different purposes within the same function. There is initially incorrect access control, later followed by an expired pointer dereference. One attack vector is sending an untrusted client certificate during EAP-TLS. A server is affected only if it loads plugins that implement TLS-based EAP methods (EAP-TLS, EAP-TTLS, EAP-PEAP, or EAP-TNC). This is fixed in 5.9.10.

CVSS 9.8 · Kritisch · EPSS 2,3% · Korrektur verfügbar

Veröffentlicht
Aktualisiert

Technologie-Stack: system

Betroffene Produkte und Versionen

  • n/a

    Softwareversionen
    • n/a: Unbekannt

    Keine Korrektur veröffentlicht

  • strongswan Debian:12

    Betroffene Versionsbereiche
    • ECOSYSTEM: < 5.9.8-4

    Auf 5.9.8-4 aktualisieren

  • strongswan Debian:13

    Betroffene Versionsbereiche
    • ECOSYSTEM: < 5.9.8-4

    Auf 5.9.8-4 aktualisieren

  • strongswan Debian:14

    Betroffene Versionsbereiche
    • ECOSYSTEM: < 5.9.8-4

    Auf 5.9.8-4 aktualisieren

Originalquellen

Prüfen Sie Ihren Server →