p PatchFirst

PatchFirst · Aktuelle Sicherheitslücken

Sicherheitslücken in @ckeditor/ckeditor5-markdown-gfm

In den letzten 30 Tagen veröffentlichte Sicherheitslücken für @ckeditor/ckeditor5-markdown-gfm: 0. Davon im KEV-Katalog: 0.

Sicherheitslücken filtern
Filter zurücksetzen

Sicherheitslücken: 3

  1. CVE-2022-31175

    Mittel · CVSS 5.8EPSS 0,88%Korrektur verfügbar

    Cross-site scripting caused by the editor instance destroying process in ckeditor5

    CKEditor 5 is a JavaScript rich text editor. A cross-site scripting vulnerability has been discovered affecting three optional CKEditor 5's packages in versions prior to 35.0.1. The vulnerability allowed to trigger a JavaScript code after fulfilling special conditions. The affected packages are `@ckeditor/ckeditor5-markdown-gfm`, `@ckeditor/ckeditor5-html-support`, and `@ckeditor/ckeditor5-html-embed`. The specific conditions are 1) Using one of the affected packages. In case of `ckeditor5-html-support` and `ckeditor5-html-embed`, additionally, it was required to use a configuration that allows unsafe markup inside the editor. 2) Destroying t

    • Auf 35.0.1 aktualisieren
    Veröffentlicht Aktualisiert
  2. CVE-2021-21391

    Mittel · CVSS 6.5EPSS 1,67%Korrektur verfügbar

    Regular expression Denial of Service in multiple packages

    CKEditor 5 provides a WYSIWYG editing solution. This CVE affects the following npm packages: ckeditor5-engine, ckeditor5-font, ckeditor5-image, ckeditor5-list, ckeditor5-markdown-gfm, ckeditor5-media-embed, ckeditor5-paste-from-office, and ckeditor5-widget. Following an internal audit, a regular expression denial of service (ReDoS) vulnerability has been discovered in multiple CKEditor 5 packages. The vulnerability allowed to abuse particular regular expressions, which could cause a significant performance drop resulting in a browser tab freeze. It affects all users using the CKEditor 5 packages listed above at version <= 26.0.0. The problem

    • Auf 27.0.0 aktualisieren
    Veröffentlicht Aktualisiert
  3. CVE-2021-21254

    Mittel · CVSS 6.5EPSS 1,81%Korrektur verfügbar

    Regular expression Denial of Service in Markdown plugin

    CKEditor 5 is an open source rich text editor framework with a modular architecture. The CKEditor 5 Markdown plugin (@ckeditor/ckeditor5-markdown-gfm) before version 25.0.0 has a regex denial of service (ReDoS) vulnerability. The vulnerability allowed to abuse link recognition regular expression, which could cause a significant performance drop resulting in browser tab freeze. It affects all users using CKEditor 5 Markdown plugin at version <= 24.0.0. The problem has been recognized and patched. The fix will be available in version 25.0.0.

    • Auf 25.0.0 aktualisieren
    Veröffentlicht Aktualisiert

Prüfen Sie Ihren Server

Gleichen Sie Ihren installierten Stack und seine Versionen mit den aktuellen Sicherheitsmeldungen ab.

Prüfen Sie Ihren Server →