p PatchFirst

CVE-2021-21391

CVE-2021-21391 · Regular expression Denial of Service in multiple packages

Diese Seite enthält Fakten aus öffentlichen Sicherheitsquellen. Lesen Sie vor dem Aktualisieren die Originalmeldung.

CKEditor 5 provides a WYSIWYG editing solution. This CVE affects the following npm packages: ckeditor5-engine, ckeditor5-font, ckeditor5-image, ckeditor5-list, ckeditor5-markdown-gfm, ckeditor5-media-embed, ckeditor5-paste-from-office, and ckeditor5-widget. Following an internal audit, a regular expression denial of service (ReDoS) vulnerability has been discovered in multiple CKEditor 5 packages. The vulnerability allowed to abuse particular regular expressions, which could cause a significant performance drop resulting in a browser tab freeze. It affects all users using the CKEditor 5 packages listed above at version <= 26.0.0. The problem has been recognized and patched. The fix will be available in version 27.0.0.

CVSS 6.5 · Mittel · EPSS 1,7% · Korrektur verfügbar

Veröffentlicht
Aktualisiert

Technologie-Stack: system · node

Betroffene Produkte und Versionen

  • ckeditor5

    Softwareversionen
    • < 27.0.0: Betroffen

    Keine Korrektur veröffentlicht

  • @ckeditor/ckeditor5-engine npm

    Betroffene Versionsbereiche
    • SEMVER: < 27.0.0

    Auf 27.0.0 aktualisieren

  • @ckeditor/ckeditor5-font npm

    Betroffene Versionsbereiche
    • SEMVER: < 27.0.0

    Auf 27.0.0 aktualisieren

  • @ckeditor/ckeditor5-image npm

    Betroffene Versionsbereiche
    • SEMVER: < 27.0.0

    Auf 27.0.0 aktualisieren

  • @ckeditor/ckeditor5-list npm

    Betroffene Versionsbereiche
    • SEMVER: < 27.0.0

    Auf 27.0.0 aktualisieren

  • @ckeditor/ckeditor5-markdown-gfm npm

    Betroffene Versionsbereiche
    • SEMVER: < 27.0.0

    Auf 27.0.0 aktualisieren

  • @ckeditor/ckeditor5-media-embed npm

    Betroffene Versionsbereiche
    • SEMVER: < 27.0.0

    Auf 27.0.0 aktualisieren

  • @ckeditor/ckeditor5-paste-from-office npm

    Betroffene Versionsbereiche
    • SEMVER: < 27.0.0

    Auf 27.0.0 aktualisieren

  • @ckeditor/ckeditor5-widget npm

    Betroffene Versionsbereiche
    • SEMVER: < 27.0.0

    Auf 27.0.0 aktualisieren

  • ckeditor3 Ubuntu:18.04:LTS

    Softwareversionen
    • 3.6.6.1+dfsg-1
    Betroffene Versionsbereiche
    • ECOSYSTEM: (−∞, +∞)

    Keine Korrektur veröffentlicht

  • ckeditor3 Ubuntu:20.04:LTS

    Softwareversionen
    • 3.6.6.1+dfsg-3
    • 3.6.6.1+dfsg-4
    Betroffene Versionsbereiche
    • ECOSYSTEM: (−∞, +∞)

    Keine Korrektur veröffentlicht

  • ckeditor3 Ubuntu:22.04:LTS

    Softwareversionen
    • 3.6.6.1+dfsg-7
    Betroffene Versionsbereiche
    • ECOSYSTEM: (−∞, +∞)

    Keine Korrektur veröffentlicht

  • ckeditor3 Ubuntu:24.04:LTS

    Softwareversionen
    • 3.6.6.1+dfsg-7
    Betroffene Versionsbereiche
    • ECOSYSTEM: (−∞, +∞)

    Keine Korrektur veröffentlicht

Originalquellen

Prüfen Sie Ihren Server →