p PatchFirst

CVE-2026-33804

CVE-2026-33804 · @fastify/middie vulnerable to middleware bypass via deprecated ignoreDuplicateSlashes option

Diese Seite enthält Fakten aus öffentlichen Sicherheitsquellen. Lesen Sie vor dem Aktualisieren die Originalmeldung.

@fastify/middie versions 9.3.1 and earlier are vulnerable to middleware bypass when the deprecated Fastify ignoreDuplicateSlashes option is enabled. The middleware path matching logic does not account for duplicate slash normalization performed by Fastify's router, allowing requests with duplicate slashes to bypass middleware authentication and authorization checks. This only affects applications using the deprecated ignoreDuplicateSlashes option. Upgrade to @fastify/middie 9.3.2 to fix this issue. There are no workarounds other than disabling the ignoreDuplicateSlashes option.

CVSS 7.4 · Hoch · EPSS 0,3% · Korrektur verfügbar

Veröffentlicht
Aktualisiert

Technologie-Stack: node

Betroffene Produkte und Versionen

  • @fastify/middie

    Softwareversionen
    • ≥ 0, < 9.3.2: Betroffen (semver)
    • 9.3.2: Nicht betroffen (semver)

    Auf 9.3.2 aktualisieren

  • @fastify/middie npm

    Betroffene Versionsbereiche
    • SEMVER: < 9.3.2

    Auf 9.3.2 aktualisieren

Originalquellen

Prüfen Sie Ihren Server →