p PatchFirst

CVE-2022-39299

CVE-2022-39299 · Signature bypass via multiple root elements in Passport-SAML

Diese Seite enthält Fakten aus öffentlichen Sicherheitsquellen. Lesen Sie vor dem Aktualisieren die Originalmeldung.

Passport-SAML is a SAML 2.0 authentication provider for Passport, the Node.js authentication library. A remote attacker may be able to bypass SAML authentication on a website using passport-saml. A successful attack requires that the attacker is in possession of an arbitrary IDP signed XML element. Depending on the IDP used, fully unauthenticated attacks (e.g without access to a valid user) might also be feasible if generation of a signed message can be triggered. Users should upgrade to passport-saml version 3.2.2 or newer. The issue was also present in the beta releases of `node-saml` before version 4.0.0-beta.5. If you cannot upgrade, disabling SAML authentication may be done as a workaround.

CVSS 7.4 · Hoch · EPSS 4,5% · Korrektur verfügbar

Veröffentlicht
Aktualisiert

Technologie-Stack: node

Betroffene Produkte und Versionen

  • passport-saml

    Softwareversionen
    • < 3.2.2: Betroffen

    Keine Korrektur veröffentlicht

  • passport-saml npm

    Betroffene Versionsbereiche
    • SEMVER: < 3.2.2

    Auf 3.2.2 aktualisieren

  • node-saml npm

    Betroffene Versionsbereiche
    • SEMVER: < 4.0.0-beta.5

    Auf 4.0.0-beta.5 aktualisieren

  • @node-saml/node-saml npm

    Betroffene Versionsbereiche
    • SEMVER: < 4.0.0-beta.5

    Auf 4.0.0-beta.5 aktualisieren

  • @node-saml/passport-saml npm

    Betroffene Versionsbereiche
    • SEMVER: < 4.0.0-beta.3

    Auf 4.0.0-beta.3 aktualisieren

Originalquellen

Prüfen Sie Ihren Server →