CVE-2020-11022
CVE-2020-11022 · jQuery has a potential XSS vulnerability
Diese Seite enthält Fakten aus öffentlichen Sicherheitsquellen. Lesen Sie vor dem Aktualisieren die Originalmeldung.
Diese Seite zeigt ausgewählte Angaben aus den Quellen. Die vollständige Beschreibung und betroffene Versionen finden Sie in den verlinkten Sicherheitshinweisen.
In jQuery starting with 1.12.0 and before 3.5.0, passing HTML from untrusted sources - even after sanitizing it - to one of jQuery's DOM manipulation methods (i.e. .html(), .append(), and others) may execute untrusted code. This problem is patched in jQuery 3.5.0.
CVSS 6.9 · Mittel · EPSS 99,2% · Öffentlicher Exploit · Korrektur verfügbar
- Veröffentlicht
- Aktualisiert
Technologie-Stack: system · php · node
Betroffene Produkte und Versionen
jquery
- Softwareversionen
- >= 1.12.0, < 3.5.0: Betroffen
Keine Korrektur veröffentlicht
node-jquery Debian:12
- Betroffene Versionsbereiche
- ECOSYSTEM: < 3.5.0+dfsg-2
Auf 3.5.0+dfsg-2 aktualisieren
node-jquery Debian:13
- Betroffene Versionsbereiche
- ECOSYSTEM: < 3.5.0+dfsg-2
Auf 3.5.0+dfsg-2 aktualisieren
node-jquery Debian:14
- Betroffene Versionsbereiche
- ECOSYSTEM: < 3.5.0+dfsg-2
Auf 3.5.0+dfsg-2 aktualisieren
znc Debian:12
- Softwareversionen
- 1.10.1-1
- 1.10.2-1
- 1.10.3-1
- 1.8.2-3.1
- 1.8.2-3.1+deb12u1
- 1.8.2-4
- 1.9.0-1
- 1.9.0-2
- 1.9.1-1
- 1.9.1-2
- Betroffene Versionsbereiche
- ECOSYSTEM: (−∞, +∞)
Keine Korrektur veröffentlicht
znc Debian:13
- Softwareversionen
- 1.10.1-1
- 1.10.2-1
- 1.10.3-1
- 1.9.1-2
- 1.9.1-2+deb13u1
- Betroffene Versionsbereiche
- ECOSYSTEM: (−∞, +∞)
Keine Korrektur veröffentlicht
znc Debian:14
- Softwareversionen
- 1.10.1-1
- 1.10.2-1
- 1.9.1-2
- Betroffene Versionsbereiche
- ECOSYSTEM: < 1.10.3-1
Auf 1.10.3-1 aktualisieren
jquery npm
- Betroffene Versionsbereiche
- SEMVER: ≥ 1.12.0, < 3.5.0
Auf 3.5.0 aktualisieren
jquery NuGet
- Softwareversionen
- 1.12.0
- 1.12.1
- 1.12.2
- 1.12.3
- 1.12.4
- 2.0.0
- 2.0.1
- 2.0.1.1
- 2.0.2
- 2.0.3
- 2.1.0
- 2.1.1
- 2.1.2
- 2.1.3
- 2.1.4
- 2.2.0
- 2.2.1
- 2.2.2
- 2.2.3
- 2.2.4
- 3.0.0
- 3.0.0.1
- 3.1.0
- 3.1.1
- 3.2.1
- 3.3.1
- 3.4.0
- 3.4.1
- Betroffene Versionsbereiche
- ECOSYSTEM: ≥ 1.12.0, < 3.5.0
Auf 3.5.0 aktualisieren
jquery-rails RubyGems
- Softwareversionen
- 0.1.1
- 0.1.2
- 0.1.3
- 0.2
- 0.2.1
- 0.2.2
- 0.2.3
- 0.2.4
- 0.2.5
- 0.2.6
- 0.2.7
- 1.0
- 1.0.1
- 1.0.10
- 1.0.11
- 1.0.12
- 1.0.13
- 1.0.14
- 1.0.15
- 1.0.16
- 1.0.17
- 1.0.18
- 1.0.19
- 1.0.2
- 1.0.3
- 1.0.4
- 1.0.5
- 1.0.6
- 1.0.7
- 1.0.8
- 1.0.9
- 1.0.rc
- 2.0.1
- 2.0.2
- 2.0.3
- 2.1.0
- 2.1.1
- 2.1.2
- 2.1.3
- 2.1.4
- 2.2.0
- 2.2.1
- 2.2.2
- 2.3.0
- 3.0.0
- 3.0.1
- 3.0.2
- 3.0.3
- 3.0.4
- 3.1.0
- 3.1.1
- 3.1.2
- 3.1.3
- 3.1.4
- 3.1.5
- 4.0.0
- 4.0.0.beta1
- 4.0.0.beta2
- 4.0.1
- 4.0.2
- 4.0.3
- 4.0.4
- 4.0.5
- 4.1.0
- 4.1.1
- 4.2.0
- 4.2.1
- 4.2.2
- 4.3.0
- 4.3.1
- 4.3.2
- 4.3.3
- 4.3.4
- 4.3.5
- Betroffene Versionsbereiche
- ECOSYSTEM: < 4.4.0
Auf 4.4.0 aktualisieren
org.webjars.npm:jquery Maven
- Softwareversionen
- 1.12.1
- 1.12.2
- 1.12.3
- 1.12.4
- 2.1.0
- 2.1.1
- 2.1.1-rc1
- 2.1.1-rc2
- 2.1.3
- 2.1.4
- 2.2.0
- 2.2.1
- 2.2.2
- 2.2.3
- 2.2.4
- 3.0.0
- 3.0.0-alpha1
- 3.0.0-beta1
- 3.0.0-rc1
- 3.1.0
- 3.1.1
- 3.2.0
- 3.2.1
- 3.3.0
- 3.3.1
- 3.4.0
- 3.4.1
- Betroffene Versionsbereiche
- ECOSYSTEM: ≥ 1.12.0, < 3.5.0
Auf 3.5.0 aktualisieren
maximebf/debugbar Packagist
- Softwareversionen
- 1.0
- 1.0.1
- 1.0.2
- 1.0.3
- 1.0.4
- 1.1
- 1.10.0
- 1.10.1
- 1.13.1
- 1.2
- 1.3
- 1.4
- 1.5
- 1.5.1
- 1.6
- 1.6.1
- 1.7
- 1.7.1
- 1.8
- 1.9
- 1.9.1
- 1.9.10
- 1.9.11
- 1.9.12
- 1.9.13
- 1.9.14
- 1.9.15
- 1.9.2
- 1.9.3
- 1.9.4
- 1.9.5
- 1.9.6
- 1.9.7
- 1.9.8
- 1.9.9
- v1.10.2
- v1.10.3
- v1.10.4
- v1.10.5
- v1.11.0
- v1.11.1
- v1.12.0
- v1.13.0
- v1.14.0
- v1.14.1
- v1.15.0
- v1.15.1
- v1.16.0
- v1.16.1
- v1.16.2
- v1.16.3
- v1.16.4
- v1.16.5
- v1.17.0
- v1.17.1
- v1.17.2
- v1.17.3
- v1.18.0
- v1.18.1
- v1.18.2
- Betroffene Versionsbereiche
- ECOSYSTEM: < 1.19.0
Auf 1.19.0 aktualisieren
athlon1600/youtube-downloader Packagist
- Softwareversionen
- v1.0.0
- v1.0.1
- v2.0.0
- v2.0.1
- v2.0.2
- v2.0.3
- v2.0.4
- v2.0.5
- v2.0.6
- v2.0.7
- v2.0.8
- v2.0.9
- v2.1.0
- v2.1.1
- v2.1.2
- v3.0.0
- v3.0.1
- v3.0.2
- v3.1.0
- v3.1.1
- v3.1.2
- v4.0.0
- Betroffene Versionsbereiche
- ECOSYSTEM: < 4.0.1
Auf 4.0.1 aktualisieren
components/jquery Packagist
- Softwareversionen
- 1.12.0
- 1.12.1
- 1.12.4
- 2.0.0
- 2.0.1
- 2.0.2
- 2.0.3
- 2.1.0
- 2.1.1
- 2.1.3
- 2.1.4
- 2.2.0
- 2.2.1
- 2.2.4
- 3.0.0
- 3.1.0
- 3.1.1
- 3.2.0
- 3.2.1
- 3.3.1
- 3.4.1
- Betroffene Versionsbereiche
- ECOSYSTEM: ≥ 1.12.0, < 3.5.0
Auf 3.5.0 aktualisieren
drupal7 Ubuntu:Pro:14.04:LTS
- Softwareversionen
- 7.23-1
- 7.24-1
- 7.24-2
- 7.26-1
- 7.26-1ubuntu0.1
- 7.26-1ubuntu0.1+esm1
- 7.26-1ubuntu0.1+esm2
- Betroffene Versionsbereiche
- ECOSYSTEM: < 7.26-1ubuntu0.1+esm3
Auf 7.26-1ubuntu0.1+esm3 aktualisieren
jquery Ubuntu:Pro:16.04:LTS
- Softwareversionen
- 1.7.2+dfsg-3ubuntu2
- 1.11.3+dfsg-4
- Betroffene Versionsbereiche
- ECOSYSTEM: < 1.11.3+dfsg-4ubuntu0.1~esm1
Auf 1.11.3+dfsg-4ubuntu0.1~esm1 aktualisieren
drupal7 Ubuntu:Pro:16.04:LTS
- Softwareversionen
- 7.38-1
- 7.41-1
- 7.44-1ubuntu1~16.04.0
- 7.44-1ubuntu1~16.04.0+esm1
- 7.44-1ubuntu1~16.04.0+esm2
- Betroffene Versionsbereiche
- ECOSYSTEM: < 7.44-1ubuntu1~16.04.0+esm3
Auf 7.44-1ubuntu1~16.04.0+esm3 aktualisieren
jquery Ubuntu:Pro:18.04:LTS
- Softwareversionen
- 3.1.1-2
- 3.2.1-1
- Betroffene Versionsbereiche
- ECOSYSTEM: < 3.2.1-1ubuntu0.1~esm1
Auf 3.2.1-1ubuntu0.1~esm1 aktualisieren
jquery Ubuntu:20.04:LTS
- Softwareversionen
- 3.3.1~dfsg-3
- Betroffene Versionsbereiche
- ECOSYSTEM: < 3.3.1~dfsg-3ubuntu0.1
Auf 3.3.1~dfsg-3ubuntu0.1 aktualisieren
Originalquellen
- https://github.com/jquery/jquery/security/advisories/GHSA-gxr4-xjj5-5px2
- https://github.com/maximebf/php-debugbar/issues/447
- https://github.com/jquery/jquery/commit/1d61fd9407e6fbe82fe55cb0b938307aa0791f77
- https://github.com/maximebf/php-debugbar/commit/847216e60544258c881f2733d699bbcfeefac0fc
- https://lists.fedoraproject.org/archives/list/[email protected]/message/VOE7P7APPRQKD4FGNHBKJPDY6FFCOH3W
- https://lists.opensuse.org/opensuse-security-announce/2020-07/msg00067.html
- https://lists.opensuse.org/opensuse-security-announce/2020-07/msg00085.html
- https://lists.opensuse.org/opensuse-security-announce/2020-11/msg00039.html
- https://packetstormsecurity.com/files/162159/jQuery-1.2-Cross-Site-Scripting.html
- https://security.gentoo.org/glsa/202007-03
- https://www.debian.org/security/2020/dsa-4693
- https://www.drupal.org/sa-core-2020-002
- https://www.oracle.com/security-alerts/cpuApr2021.html
- https://www.oracle.com/security-alerts/cpuapr2022.html
- https://www.oracle.com/security-alerts/cpujan2021.html
- https://www.oracle.com/security-alerts/cpujan2022.html
- https://www.oracle.com/security-alerts/cpujul2020.html
- https://www.oracle.com/security-alerts/cpujul2021.html
- https://www.oracle.com/security-alerts/cpujul2022.html
- https://www.oracle.com/security-alerts/cpuoct2020.html
- https://www.oracle.com/security-alerts/cpuoct2021.html
- https://www.tenable.com/security/tns-2020-10
- https://www.tenable.com/security/tns-2020-11
- https://nvd.nist.gov/vuln/detail/CVE-2020-11022