p PatchFirst

PatchFirst · Aktuelle Sicherheitslücken

Sicherheitslücken in ldap-account-manager · Seite 2

In den letzten 30 Tagen veröffentlichte Sicherheitslücken für ldap-account-manager: 3. Davon im KEV-Katalog: 0.

Sicherheitslücken filtern
Filter zurücksetzen

Sicherheitslücken: 28

  1. CVE-2022-31086

    Mittel · CVSS 6.6EPSS 2,29%Keine Korrektur veröffentlicht

    Incorrect Regular Expressions in ldap-account-manager

    LDAP Account Manager (LAM) is a webfrontend for managing entries (e.g. users, groups, DHCP settings) stored in an LDAP directory. In versions prior to 8.0 incorrect regular expressions allow to upload PHP scripts to config/templates/pdf. This vulnerability could lead to a Remote Code Execution if the /config/templates/pdf/ directory is accessible for remote users. This is not a default configuration of LAM. This issue has been fixed in version 8.0. There are no known workarounds for this issue.

    Veröffentlicht Aktualisiert
  2. CVE-2022-31087

    Hoch · CVSS 7.8EPSS 0,44%Keine Korrektur veröffentlicht

    Incorrect Default Permissions in ldap-account-manager

    LDAP Account Manager (LAM) is a webfrontend for managing entries (e.g. users, groups, DHCP settings) stored in an LDAP directory. In versions prior to 8.0 the tmp directory, which is accessible by /lam/tmp/, allows interpretation of .php (and .php5/.php4/.phpt/etc) files. An attacker capable of writing files under www-data privileges can write a web-shell into this directory, and gain a Code Execution on the host. This issue has been fixed in version 8.0. Users unable to upgrade should disallow executing PHP scripts in (/var/lib/ldap-account-manager/)tmp directory.

    Veröffentlicht Aktualisiert
  3. CVE-2022-31088

    Mittel · CVSS 6.5EPSS 1,31%Keine Korrektur veröffentlicht

    Unauthenticated LDAP Injection in ldap-account-manager

    LDAP Account Manager (LAM) is a webfrontend for managing entries (e.g. users, groups, DHCP settings) stored in an LDAP directory. In versions prior to 8.0 the user name field at login could be used to enumerate LDAP data. This is only the case for LDAP search configuration. This issue has been fixed in version 8.0.

    Veröffentlicht Aktualisiert
  4. CVE-2022-24729

    Mittel · CVSS 6.5EPSS 2,49%Keine Korrektur veröffentlicht

    Regular expression Denial of Service in dialog plugin

    CKEditor4 is an open source what-you-see-is-what-you-get HTML editor. CKEditor4 prior to version 4.18.0 contains a vulnerability in the `dialog` plugin. The vulnerability allows abuse of a dialog input validator regular expression, which can cause a significant performance drop resulting in a browser tab freeze. A patch is available in version 4.18.0. There are currently no known workarounds.

    Veröffentlicht Aktualisiert
  5. CVE-2022-24728

    Mittel · CVSS 5.4EPSS 1,2%Keine Korrektur veröffentlicht

    Cross-site Scripting in CKEditor4

    CKEditor4 is an open source what-you-see-is-what-you-get HTML editor. A vulnerability has been discovered in the core HTML processing module and may affect all plugins used by CKEditor 4 prior to version 4.18.0. The vulnerability allows someone to inject malformed HTML bypassing content sanitization, which could result in executing JavaScript code. This problem has been patched in version 4.18.0. There are currently no known workarounds.

    Veröffentlicht Aktualisiert
  6. CVE-2021-41165

    Hoch · CVSS 8.2EPSS 1,57%Keine Korrektur veröffentlicht

    HTML comments vulnerability allowing to execute JavaScript code

    CKEditor4 is an open source WYSIWYG HTML editor. In affected version a vulnerability has been discovered in the core HTML processing module and may affect all plugins used by CKEditor 4. The vulnerability allowed to inject malformed comments HTML bypassing content sanitization, which could result in executing JavaScript code. It affects all users using the CKEditor 4 at version < 4.17.0. The problem has been recognized and patched. The fix will be available in version 4.17.0.

    Veröffentlicht Aktualisiert
  7. CVE-2021-41164

    Hoch · CVSS 8.2EPSS 1,35%Keine Korrektur veröffentlicht

    Advanced Content Filter (ACF) vulnerability allowing to execute JavaScript code using malformed HTML

    CKEditor4 is an open source WYSIWYG HTML editor. In affected versions a vulnerability has been discovered in the Advanced Content Filter (ACF) module and may affect all plugins used by CKEditor 4. The vulnerability allowed to inject malformed HTML bypassing content sanitization, which could result in executing JavaScript code. It affects all users using the CKEditor 4 at version < 4.17.0. The problem has been recognized and patched. The fix will be available in version 4.17.0.

    Veröffentlicht Aktualisiert
  8. CVE-2021-37695

    Hoch · CVSS 7.3EPSS 1,32%Keine Korrektur veröffentlicht

    Execution of JavaScript code using malformed HTML in ckeditor

    ckeditor is an open source WYSIWYG HTML editor with rich content support. A potential vulnerability has been discovered in CKEditor 4 [Fake Objects](https://ckeditor.com/cke4/addon/fakeobjects) package. The vulnerability allowed to inject malformed Fake Objects HTML, which could result in executing JavaScript code. It affects all users using the CKEditor 4 plugins listed above at version < 4.16.2. The problem has been recognized and patched. The fix will be available in version 4.16.2.

    Veröffentlicht Aktualisiert

Prüfen Sie Ihren Server

Gleichen Sie Ihren installierten Stack und seine Versionen mit den aktuellen Sicherheitsmeldungen ab.

Prüfen Sie Ihren Server →