p PatchFirst

CVE-2021-35940

CVE-2021-35940 · Regression of CVE-2017-12613

Diese Seite enthält Fakten aus öffentlichen Sicherheitsquellen. Lesen Sie vor dem Aktualisieren die Originalmeldung.

An out-of-bounds array read in the apr_time_exp*() functions was fixed in the Apache Portable Runtime 1.6.3 release (CVE-2017-12613). The fix for this issue was not carried forward to the APR 1.7.x branch, and hence version 1.7.0 regressed compared to 1.6.3 and is vulnerable to the same issue.

CVSS 7.1 · Hoch · EPSS 1,2% · Korrektur verfügbar

Veröffentlicht
Aktualisiert

Technologie-Stack: system

Betroffene Produkte und Versionen

  • apache portable runtime (apr)

    Softwareversionen
    • Apache Portable Runtime 1.7.0: Betroffen

    Keine Korrektur veröffentlicht

  • apr Debian:12

    Betroffene Versionsbereiche
    • ECOSYSTEM: < 1.7.0-7

    Auf 1.7.0-7 aktualisieren

  • apr Debian:13

    Betroffene Versionsbereiche
    • ECOSYSTEM: < 1.7.0-7

    Auf 1.7.0-7 aktualisieren

  • apr Debian:14

    Betroffene Versionsbereiche
    • ECOSYSTEM: < 1.7.0-7

    Auf 1.7.0-7 aktualisieren

  • apr Ubuntu:Pro:14.04:LTS

    Softwareversionen
    • 1.4.8-1ubuntu1
    • 1.4.8-2
    • 1.4.8-3
    • 1.5.0-1
    Betroffene Versionsbereiche
    • ECOSYSTEM: < 1.5.0-1ubuntu0.1~esm1

    Auf 1.5.0-1ubuntu0.1~esm1 aktualisieren

  • apr Ubuntu:Pro:16.04:LTS

    Softwareversionen
    • 1.5.2-3
    Betroffene Versionsbereiche
    • ECOSYSTEM: < 1.5.2-3ubuntu0.1~esm1

    Auf 1.5.2-3ubuntu0.1~esm1 aktualisieren

  • apr Ubuntu:22.04:LTS

    Betroffene Versionsbereiche
    • ECOSYSTEM: < 1.7.0-6ubuntu1

    Auf 1.7.0-6ubuntu1 aktualisieren

Originalquellen

Prüfen Sie Ihren Server →