p PatchFirst

PatchFirst · Aktuelle Sicherheitslücken

Sicherheitslücken in netty · Seite 6

In den letzten 30 Tagen veröffentlichte Sicherheitslücken für netty: 0. Davon im KEV-Katalog: 0.

Sicherheitslücken filtern
Filter zurücksetzen

Sicherheitslücken: 114

  1. CVE-2022-41881

    Mittel · CVSS 5.3EPSS 1,58%Korrektur verfügbar

    CVE-2022-41881

    Netty project is an event-driven asynchronous network application framework. In versions prior to 4.1.86.Final, a StackOverflowError can be raised when parsing a malformed crafted message due to an infinite recursion. This issue is patched in version 4.1.86.Final. There is no workaround, except using a custom HaProxyMessageDecoder.

    • Auf 1:4.0.34-1ubuntu0.1~esm1 aktualisieren
    Veröffentlicht Aktualisiert
  2. CVE-2022-24823

    Mittel · CVSS 5.5EPSS 1,04%Korrektur verfügbar

    Local Information Disclosure Vulnerability in io.netty:netty-codec-http

    Netty is an open-source, asynchronous event-driven network application framework. The package `io.netty:netty-codec-http` prior to version 4.1.77.Final contains an insufficient fix for CVE-2021-21290. When Netty's multipart decoders are used local information disclosure can occur via the local system temporary directory if temporary storing uploads on the disk is enabled. This only impacts applications running on Java version 6 and lower. Additionally, this vulnerability impacts code running on Unix-like systems, and very old versions of Mac OSX and Windows as they all share the system temporary directory between all users. Version 4.1.77.Fin

    • Auf 1:4.0.34-1ubuntu0.1~esm2 aktualisieren
    Veröffentlicht Aktualisiert
  3. CVE-2021-43797

    Mittel · CVSS 6.5EPSS 2,88%Korrektur verfügbar

    HTTP fails to validate against control chars in header names which may lead to HTTP request smuggling

    Netty is an asynchronous event-driven network application framework for rapid development of maintainable high performance protocol servers & clients. Netty prior to version 4.1.71.Final skips control chars when they are present at the beginning / end of the header name. It should instead fail fast as these are not allowed by the spec and could lead to HTTP request smuggling. Failing to do the validation might cause netty to "sanitize" header names before it forward these to another remote system when used as proxy. This remote system can't see the invalid usage anymore, and therefore does not do the validation itself. Users should upgrade to

    • Auf 1:4.0.34-1ubuntu0.1~esm1 aktualisieren
    Veröffentlicht Aktualisiert
  4. CVE-2021-37137

    Hoch · CVSS 7.5EPSS 6,57%Korrektur verfügbar

    CVE-2021-37137

    The Snappy frame decoder function doesn't restrict the chunk length which may lead to excessive memory usage. Beside this it also may buffer reserved skippable chunks until the whole chunk was received which may lead to excessive memory usage as well. This vulnerability can be triggered by supplying malicious input that decompresses to a very big size (via a network stream or a file) or by sending a huge skippable chunk.

    • Auf 1:4.0.34-1ubuntu0.1~esm1 aktualisieren
    Veröffentlicht Aktualisiert
  5. CVE-2021-37136

    Hoch · CVSS 7.5EPSS 5,91%Korrektur verfügbar

    CVE-2021-37136

    The Bzip2 decompression decoder function doesn't allow setting size restrictions on the decompressed output data (which affects the allocation size used during decompression). All users of Bzip2Decoder are affected. The malicious input can trigger an OOME and so a DoS attack

    • Auf 1:4.0.34-1ubuntu0.1~esm1 aktualisieren
    Veröffentlicht Aktualisiert
  6. CVE-2021-21409

    Mittel · CVSS 5.9EPSS 4,93%Korrektur verfügbar

    Possible request smuggling in HTTP/2 due missing validation of content-length

    Netty is an open-source, asynchronous event-driven network application framework for rapid development of maintainable high performance protocol servers & clients. In Netty (io.netty:netty-codec-http2) before version 4.1.61.Final there is a vulnerability that enables request smuggling. The content-length header is not correctly validated if the request only uses a single Http2HeaderFrame with the endStream set to to true. This could lead to request smuggling if the request is proxied to a remote peer and translated to HTTP/1.1. This is a followup of GHSA-wm47-8v5p-wjpj/CVE-2021-21295 which did miss to fix this one case. This was fixed as part

    • Auf 1:4.0.34-1ubuntu0.1~esm1 aktualisieren
    Veröffentlicht Aktualisiert
  7. CVE-2021-21295

    Mittel · CVSS 5.9EPSS 18,89%Korrektur verfügbar

    Possible request smuggling in HTTP/2 due missing validation

    Netty is an open-source, asynchronous event-driven network application framework for rapid development of maintainable high performance protocol servers & clients. In Netty (io.netty:netty-codec-http2) before version 4.1.60.Final there is a vulnerability that enables request smuggling. If a Content-Length header is present in the original HTTP/2 request, the field is not validated by `Http2MultiplexHandler` as it is propagated up. This is fine as long as the request is not proxied through as HTTP/1.1. If the request comes in as an HTTP/2 stream, gets converted into the HTTP/1.1 domain objects (`HttpRequest`, `HttpContent`, etc.) via `Http2Str

    • Auf 1:4.0.34-1ubuntu0.1~esm1 aktualisieren
    Veröffentlicht Aktualisiert
  8. CVE-2021-21290

    Mittel · CVSS 6.2EPSS 1,78%Korrektur verfügbar

    Local Information Disclosure Vulnerability in Netty on Unix-Like systems due temporary files

    Netty is an open-source, asynchronous event-driven network application framework for rapid development of maintainable high performance protocol servers & clients. In Netty before version 4.1.59.Final there is a vulnerability on Unix-like systems involving an insecure temp file. When netty's multipart decoders are used local information disclosure can occur via the local system temporary directory if temporary storing uploads on the disk is enabled. On unix-like systems, the temporary directory is shared between all user. As such, writing to this directory using APIs that do not explicitly set the file/directory permissions can lead to inform

    • Auf 1:4.0.34-1ubuntu0.1~esm1 aktualisieren
    Veröffentlicht Aktualisiert
  9. CVE-2020-11612

    Hoch · CVSS 7.5EPSS 9,19%Korrektur verfügbar

    CVE-2020-11612

    The ZlibDecoders in Netty 4.1.x before 4.1.46 allow for unbounded memory allocation while decoding a ZlibEncoded byte stream. An attacker could send a large ZlibEncoded byte stream to the Netty server, forcing the server to allocate all of its free memory to a single decoder.

    • Auf 1:4.0.34-1ubuntu0.1~esm1 aktualisieren
    Veröffentlicht Aktualisiert

Prüfen Sie Ihren Server

Gleichen Sie Ihren installierten Stack und seine Versionen mit den aktuellen Sicherheitsmeldungen ab.

Prüfen Sie Ihren Server →