p PatchFirst

PatchFirst · Aktuelle Sicherheitslücken

Sicherheitslücken in rails · Seite 3

In den letzten 30 Tagen veröffentlichte Sicherheitslücken für rails: 0. Davon im KEV-Katalog: 0.

Sicherheitslücken filtern
Filter zurücksetzen

Sicherheitslücken: 58

  1. CVE-2021-22903

    Mittel · CVSS 6.1EPSS 1,23%Keine Korrektur veröffentlicht

    CVE-2021-22903

    The actionpack ruby gem before 6.1.3.2 suffers from a possible open redirect vulnerability. Specially crafted Host headers in combination with certain "allowed host" formats can cause the Host Authorization middleware in Action Pack to redirect users to a malicious website. This is similar to CVE-2021-22881. Strings in config.hosts that do not have a leading dot are converted to regular expressions without proper escaping. This causes, for example, `config.hosts << "sub.example.com"` to permit a request with a Host header value of `sub-example.com`.

    Veröffentlicht Aktualisiert
  2. CVE-2021-22902

    Hoch · CVSS 7.5EPSS 2,87%Keine Korrektur veröffentlicht

    CVE-2021-22902

    The actionpack ruby gem (a framework for handling and responding to web requests in Rails) before 6.0.3.7, 6.1.3.2 suffers from a possible denial of service vulnerability in the Mime type parser of Action Dispatch. Carefully crafted Accept headers can cause the mime type parser in Action Dispatch to do catastrophic backtracking in the regular expression engine.

    Veröffentlicht Aktualisiert
  3. CVE-2021-22881

    Mittel · CVSS 6.1EPSS 87,3%Öffentlicher ExploitKeine Korrektur veröffentlicht

    CVE-2021-22881

    The Host Authorization middleware in Action Pack before 6.1.2.1, 6.0.3.5 suffers from an open redirect vulnerability. Specially crafted `Host` headers in combination with certain "allowed host" formats can cause the Host Authorization middleware in Action Pack to redirect users to a malicious website. Impacted applications will have allowed hosts with a leading dot. When an allowed host contains a leading dot, a specially crafted `Host` header can be used to redirect to a malicious website.

    Veröffentlicht Aktualisiert
  4. CVE-2021-22880

    Hoch · CVSS 7.5EPSS 4,43%Öffentlicher ExploitKeine Korrektur veröffentlicht

    CVE-2021-22880

    The PostgreSQL adapter in Active Record before 6.1.2.1, 6.0.3.5, 5.2.4.5 suffers from a regular expression denial of service (REDoS) vulnerability. Carefully crafted input can cause the input validation in the `money` type of the PostgreSQL adapter in Active Record to spend too much time in a regular expression, resulting in the potential for a DoS attack. This only impacts Rails applications that are using PostgreSQL along with money type columns that take user input.

    Veröffentlicht Aktualisiert
  5. CVE-2020-15169

    Mittel · CVSS 5.4EPSS 2,37%Keine Korrektur veröffentlicht

    XSS in Action View

    In Action View before versions 5.2.4.4 and 6.0.3.3 there is a potential Cross-Site Scripting (XSS) vulnerability in Action View's translation helpers. Views that allow the user to control the default (not found) value of the `t` and `translate` helpers could be susceptible to XSS attacks. When an HTML-unsafe string is passed as the default for a missing translation key named html or ending in _html, the default string is incorrectly marked as HTML-safe and not escaped. This is patched in versions 6.0.3.3 and 5.2.4.4. A workaround without upgrading is proposed in the source advisory.

    Veröffentlicht Aktualisiert
  6. CVE-2020-5267

    Mittel · CVSS 4EPSS 1,52%Keine Korrektur veröffentlicht

    Possible XSS vulnerability in ActionView

    In ActionView before versions 6.0.2.2 and 5.2.4.2, there is a possible XSS vulnerability in ActionView's JavaScript literal escape helpers. Views that use the `j` or `escape_javascript` methods may be susceptible to XSS attacks. The issue is fixed in versions 6.0.2.2 and 5.2.4.2.

    Veröffentlicht Aktualisiert
  7. CVE-2019-5418

    Hoch · CVSS 7.5EPSS 98,51%Im KEV-KatalogÖffentlicher ExploitKorrektur verfügbar

    CVE-2019-5418

    There is a File Content Disclosure vulnerability in Action View <5.2.2.1, <5.1.6.2, <5.0.7.2, <4.2.11.1 and v3 where specially crafted accept headers can cause contents of arbitrary files on the target system's filesystem to be exposed.

    • Auf 2:4.2.10-0ubuntu4+esm2 aktualisieren
    Veröffentlicht Aktualisiert
  8. CVE-2018-16476

    Hoch · CVSS 7.5EPSS 2,86%Keine Korrektur veröffentlicht

    CVE-2018-16476

    A Broken Access Control vulnerability in Active Job versions >= 4.2.0 allows an attacker to craft user input which can cause Active Job to deserialize it using GlobalId and give them access to information that they should not have. This vulnerability has been fixed in versions 4.2.11, 5.0.7.1, 5.1.6.1, and 5.2.1.1.

    Veröffentlicht Aktualisiert

Prüfen Sie Ihren Server

Gleichen Sie Ihren installierten Stack und seine Versionen mit den aktuellen Sicherheitsmeldungen ab.

Prüfen Sie Ihren Server →