ALPINE-CVE-2020-8927
ALPINE-CVE-2020-8927
Esta página presenta datos de fuentes públicas de vulnerabilidades. Consulta el aviso original antes de actualizar.
A buffer overflow exists in the Brotli library versions prior to 1.0.8 where an attacker controlling the input length of a "one-shot" decompression request to a script can trigger a crash, which happens when copying over chunks of data larger than 2 GiB. It is recommended to update your Brotli library to 1.0.8 or later. If one cannot update, we recommend to use the "streaming" API as opposed to the "one-shot" API, and impose chunk size limits.
CVSS 6.5 · Media · Corrección disponible
- Publicación
- Actualización
Pila tecnológica: system
Productos y versiones afectados
brotli Alpine:v3.12
- Intervalos de versiones afectados
- ECOSYSTEM: < 1.0.9-r0
Actualiza a 1.0.9-r0
brotli Alpine:v3.13
- Intervalos de versiones afectados
- ECOSYSTEM: < 1.0.9-r0
Actualiza a 1.0.9-r0
brotli Alpine:v3.14
- Intervalos de versiones afectados
- ECOSYSTEM: < 1.0.9-r0
Actualiza a 1.0.9-r0
brotli Alpine:v3.15
- Intervalos de versiones afectados
- ECOSYSTEM: < 1.0.9-r0
Actualiza a 1.0.9-r0
brotli Alpine:v3.16
- Intervalos de versiones afectados
- ECOSYSTEM: < 1.0.9-r0
Actualiza a 1.0.9-r0
brotli Alpine:v3.17
- Intervalos de versiones afectados
- ECOSYSTEM: < 1.0.9-r0
Actualiza a 1.0.9-r0
brotli Alpine:v3.18
- Intervalos de versiones afectados
- ECOSYSTEM: < 1.0.9-r0
Actualiza a 1.0.9-r0
brotli Alpine:v3.19
- Intervalos de versiones afectados
- ECOSYSTEM: < 1.0.9-r0
Actualiza a 1.0.9-r0
brotli Alpine:v3.20
- Intervalos de versiones afectados
- ECOSYSTEM: < 1.0.9-r0
Actualiza a 1.0.9-r0
brotli Alpine:v3.21
- Intervalos de versiones afectados
- ECOSYSTEM: < 1.0.9-r0
Actualiza a 1.0.9-r0
brotli Alpine:v3.22
- Intervalos de versiones afectados
- ECOSYSTEM: < 1.0.9-r0
Actualiza a 1.0.9-r0
brotli Alpine:v3.23
- Intervalos de versiones afectados
- ECOSYSTEM: < 1.0.9-r0
Actualiza a 1.0.9-r0
brotli Alpine:v3.24
- Intervalos de versiones afectados
- ECOSYSTEM: < 1.0.9-r0
Actualiza a 1.0.9-r0