ALPINE-CVE-2020-8927
ALPINE-CVE-2020-8927
This page contains facts from public vulnerability sources. Check the original advisory before updating.
A buffer overflow exists in the Brotli library versions prior to 1.0.8 where an attacker controlling the input length of a "one-shot" decompression request to a script can trigger a crash, which happens when copying over chunks of data larger than 2 GiB. It is recommended to update your Brotli library to 1.0.8 or later. If one cannot update, we recommend to use the "streaming" API as opposed to the "one-shot" API, and impose chunk size limits.
CVSS 6.5 · Medium · Fix available
- Published
- Updated
Stack: system
Affected products and versions
brotli Alpine:v3.12
- Affected ranges
- ECOSYSTEM: < 1.0.9-r0
Update to 1.0.9-r0
brotli Alpine:v3.13
- Affected ranges
- ECOSYSTEM: < 1.0.9-r0
Update to 1.0.9-r0
brotli Alpine:v3.14
- Affected ranges
- ECOSYSTEM: < 1.0.9-r0
Update to 1.0.9-r0
brotli Alpine:v3.15
- Affected ranges
- ECOSYSTEM: < 1.0.9-r0
Update to 1.0.9-r0
brotli Alpine:v3.16
- Affected ranges
- ECOSYSTEM: < 1.0.9-r0
Update to 1.0.9-r0
brotli Alpine:v3.17
- Affected ranges
- ECOSYSTEM: < 1.0.9-r0
Update to 1.0.9-r0
brotli Alpine:v3.18
- Affected ranges
- ECOSYSTEM: < 1.0.9-r0
Update to 1.0.9-r0
brotli Alpine:v3.19
- Affected ranges
- ECOSYSTEM: < 1.0.9-r0
Update to 1.0.9-r0
brotli Alpine:v3.20
- Affected ranges
- ECOSYSTEM: < 1.0.9-r0
Update to 1.0.9-r0
brotli Alpine:v3.21
- Affected ranges
- ECOSYSTEM: < 1.0.9-r0
Update to 1.0.9-r0
brotli Alpine:v3.22
- Affected ranges
- ECOSYSTEM: < 1.0.9-r0
Update to 1.0.9-r0
brotli Alpine:v3.23
- Affected ranges
- ECOSYSTEM: < 1.0.9-r0
Update to 1.0.9-r0
brotli Alpine:v3.24
- Affected ranges
- ECOSYSTEM: < 1.0.9-r0
Update to 1.0.9-r0