ALPINE-CVE-2020-8927
ALPINE-CVE-2020-8927
Cette page présente des faits issus de sources publiques. Consultez l’avis original avant toute mise à jour.
A buffer overflow exists in the Brotli library versions prior to 1.0.8 where an attacker controlling the input length of a "one-shot" decompression request to a script can trigger a crash, which happens when copying over chunks of data larger than 2 GiB. It is recommended to update your Brotli library to 1.0.8 or later. If one cannot update, we recommend to use the "streaming" API as opposed to the "one-shot" API, and impose chunk size limits.
CVSS 6.5 · Moyenne · Correctif disponible
- Publication
- Mise à jour
Pile logicielle: system
Produits et versions concernés
brotli Alpine:v3.12
- Plages de versions concernées
- ECOSYSTEM: < 1.0.9-r0
Mettez à jour vers 1.0.9-r0
brotli Alpine:v3.13
- Plages de versions concernées
- ECOSYSTEM: < 1.0.9-r0
Mettez à jour vers 1.0.9-r0
brotli Alpine:v3.14
- Plages de versions concernées
- ECOSYSTEM: < 1.0.9-r0
Mettez à jour vers 1.0.9-r0
brotli Alpine:v3.15
- Plages de versions concernées
- ECOSYSTEM: < 1.0.9-r0
Mettez à jour vers 1.0.9-r0
brotli Alpine:v3.16
- Plages de versions concernées
- ECOSYSTEM: < 1.0.9-r0
Mettez à jour vers 1.0.9-r0
brotli Alpine:v3.17
- Plages de versions concernées
- ECOSYSTEM: < 1.0.9-r0
Mettez à jour vers 1.0.9-r0
brotli Alpine:v3.18
- Plages de versions concernées
- ECOSYSTEM: < 1.0.9-r0
Mettez à jour vers 1.0.9-r0
brotli Alpine:v3.19
- Plages de versions concernées
- ECOSYSTEM: < 1.0.9-r0
Mettez à jour vers 1.0.9-r0
brotli Alpine:v3.20
- Plages de versions concernées
- ECOSYSTEM: < 1.0.9-r0
Mettez à jour vers 1.0.9-r0
brotli Alpine:v3.21
- Plages de versions concernées
- ECOSYSTEM: < 1.0.9-r0
Mettez à jour vers 1.0.9-r0
brotli Alpine:v3.22
- Plages de versions concernées
- ECOSYSTEM: < 1.0.9-r0
Mettez à jour vers 1.0.9-r0
brotli Alpine:v3.23
- Plages de versions concernées
- ECOSYSTEM: < 1.0.9-r0
Mettez à jour vers 1.0.9-r0
brotli Alpine:v3.24
- Plages de versions concernées
- ECOSYSTEM: < 1.0.9-r0
Mettez à jour vers 1.0.9-r0