CVE-2018-1000622
CVE-2018-1000622
This page contains facts from public vulnerability sources. Check the original advisory before updating.
The Rust Programming Language rustdoc version Between 0.8 and 1.27.0 contains a CWE-427: Uncontrolled Search Path Element vulnerability in rustdoc plugins that can result in local code execution as a different user. This attack appear to be exploitable via using the --plugin flag without the --plugin-path flag. This vulnerability appears to have been fixed in 1.27.1.
CVSS 7.8 · High · EPSS 1.8% · Fix available
- Published
- Updated
Stack: system
Affected products and versions
n/a
- Versions
- n/a: Affected
No fix published
rustc Debian:12
- Affected ranges
- ECOSYSTEM: < 1.27.1+dfsg1-1~exp1
Update to 1.27.1+dfsg1-1~exp1
rustc Debian:13
- Affected ranges
- ECOSYSTEM: < 1.27.1+dfsg1-1~exp1
Update to 1.27.1+dfsg1-1~exp1
rustc Debian:14
- Affected ranges
- ECOSYSTEM: < 1.27.1+dfsg1-1~exp1
Update to 1.27.1+dfsg1-1~exp1
Original sources
- https://security.gentoo.org/glsa/201812-11
- https://groups.google.com/forum/#%21topic/rustlang-security-announcements/4ybxYLTtXuM
- http://lists.opensuse.org/opensuse-security-announce/2019-09/msg00076.html
- http://lists.opensuse.org/opensuse-security-announce/2019-10/msg00006.html
- http://lists.opensuse.org/opensuse-security-announce/2019-10/msg00031.html
- https://nvd.nist.gov/vuln/detail/CVE-2018-1000622