p PatchFirst

CVE-2018-1000810

CVE-2018-1000810

This page contains facts from public vulnerability sources. Check the original advisory before updating.

The Rust Programming Language Standard Library version 1.29.0, 1.28.0, 1.27.2, 1.27.1, 127.0, 126.2, 126.1, 126.0 contains a CWE-680: Integer Overflow to Buffer Overflow vulnerability in standard library that can result in buffer overflow. This attack appear to be exploitable via str::repeat, passed a large number, can overflow an internal buffer. This vulnerability appears to have been fixed in 1.29.1.

CVSS 9.8 · Critical · EPSS 3.0% · Fix available

Published
Updated

Stack: system

Affected products and versions

  • n/a

    Versions
    • n/a: Affected

    No fix published

  • rustc Debian:12

    Affected ranges
    • ECOSYSTEM: < 1.30.0+dfsg1-1

    Update to 1.30.0+dfsg1-1

  • rustc Debian:13

    Affected ranges
    • ECOSYSTEM: < 1.30.0+dfsg1-1

    Update to 1.30.0+dfsg1-1

  • rustc Debian:14

    Affected ranges
    • ECOSYSTEM: < 1.30.0+dfsg1-1

    Update to 1.30.0+dfsg1-1

Original sources

Check your server →