p PatchFirst

CVE-2021-21391

CVE-2021-21391 · Regular expression Denial of Service in multiple packages

Esta página presenta datos de fuentes públicas de vulnerabilidades. Consulta el aviso original antes de actualizar.

CKEditor 5 provides a WYSIWYG editing solution. This CVE affects the following npm packages: ckeditor5-engine, ckeditor5-font, ckeditor5-image, ckeditor5-list, ckeditor5-markdown-gfm, ckeditor5-media-embed, ckeditor5-paste-from-office, and ckeditor5-widget. Following an internal audit, a regular expression denial of service (ReDoS) vulnerability has been discovered in multiple CKEditor 5 packages. The vulnerability allowed to abuse particular regular expressions, which could cause a significant performance drop resulting in a browser tab freeze. It affects all users using the CKEditor 5 packages listed above at version <= 26.0.0. The problem has been recognized and patched. The fix will be available in version 27.0.0.

CVSS 6.5 · Media · EPSS 1,7% · Corrección disponible

Publicación
Actualización

Pila tecnológica: system · node

Productos y versiones afectados

  • ckeditor5

    Versiones
    • < 27.0.0: Afectada

    Sin corrección publicada

  • @ckeditor/ckeditor5-engine npm

    Intervalos de versiones afectados
    • SEMVER: < 27.0.0

    Actualiza a 27.0.0

  • @ckeditor/ckeditor5-font npm

    Intervalos de versiones afectados
    • SEMVER: < 27.0.0

    Actualiza a 27.0.0

  • @ckeditor/ckeditor5-image npm

    Intervalos de versiones afectados
    • SEMVER: < 27.0.0

    Actualiza a 27.0.0

  • @ckeditor/ckeditor5-list npm

    Intervalos de versiones afectados
    • SEMVER: < 27.0.0

    Actualiza a 27.0.0

  • @ckeditor/ckeditor5-markdown-gfm npm

    Intervalos de versiones afectados
    • SEMVER: < 27.0.0

    Actualiza a 27.0.0

  • @ckeditor/ckeditor5-media-embed npm

    Intervalos de versiones afectados
    • SEMVER: < 27.0.0

    Actualiza a 27.0.0

  • @ckeditor/ckeditor5-paste-from-office npm

    Intervalos de versiones afectados
    • SEMVER: < 27.0.0

    Actualiza a 27.0.0

  • @ckeditor/ckeditor5-widget npm

    Intervalos de versiones afectados
    • SEMVER: < 27.0.0

    Actualiza a 27.0.0

  • ckeditor3 Ubuntu:18.04:LTS

    Versiones
    • 3.6.6.1+dfsg-1
    Intervalos de versiones afectados
    • ECOSYSTEM: (−∞, +∞)

    Sin corrección publicada

  • ckeditor3 Ubuntu:20.04:LTS

    Versiones
    • 3.6.6.1+dfsg-3
    • 3.6.6.1+dfsg-4
    Intervalos de versiones afectados
    • ECOSYSTEM: (−∞, +∞)

    Sin corrección publicada

  • ckeditor3 Ubuntu:22.04:LTS

    Versiones
    • 3.6.6.1+dfsg-7
    Intervalos de versiones afectados
    • ECOSYSTEM: (−∞, +∞)

    Sin corrección publicada

  • ckeditor3 Ubuntu:24.04:LTS

    Versiones
    • 3.6.6.1+dfsg-7
    Intervalos de versiones afectados
    • ECOSYSTEM: (−∞, +∞)

    Sin corrección publicada

Fuentes originales

Comprueba tu servidor →