p PatchFirst

CVE-2021-21391

CVE-2021-21391 · Regular expression Denial of Service in multiple packages

Cette page présente des faits issus de sources publiques. Consultez l’avis original avant toute mise à jour.

CKEditor 5 provides a WYSIWYG editing solution. This CVE affects the following npm packages: ckeditor5-engine, ckeditor5-font, ckeditor5-image, ckeditor5-list, ckeditor5-markdown-gfm, ckeditor5-media-embed, ckeditor5-paste-from-office, and ckeditor5-widget. Following an internal audit, a regular expression denial of service (ReDoS) vulnerability has been discovered in multiple CKEditor 5 packages. The vulnerability allowed to abuse particular regular expressions, which could cause a significant performance drop resulting in a browser tab freeze. It affects all users using the CKEditor 5 packages listed above at version <= 26.0.0. The problem has been recognized and patched. The fix will be available in version 27.0.0.

CVSS 6.5 · Moyenne · EPSS 1,7% · Correctif disponible

Publication
Mise à jour

Pile logicielle: system · node

Produits et versions concernés

  • ckeditor5

    Versions du logiciel
    • < 27.0.0: Concernée

    Aucun correctif publié

  • @ckeditor/ckeditor5-engine npm

    Plages de versions concernées
    • SEMVER: < 27.0.0

    Mettez à jour vers 27.0.0

  • @ckeditor/ckeditor5-font npm

    Plages de versions concernées
    • SEMVER: < 27.0.0

    Mettez à jour vers 27.0.0

  • @ckeditor/ckeditor5-image npm

    Plages de versions concernées
    • SEMVER: < 27.0.0

    Mettez à jour vers 27.0.0

  • @ckeditor/ckeditor5-list npm

    Plages de versions concernées
    • SEMVER: < 27.0.0

    Mettez à jour vers 27.0.0

  • @ckeditor/ckeditor5-markdown-gfm npm

    Plages de versions concernées
    • SEMVER: < 27.0.0

    Mettez à jour vers 27.0.0

  • @ckeditor/ckeditor5-media-embed npm

    Plages de versions concernées
    • SEMVER: < 27.0.0

    Mettez à jour vers 27.0.0

  • @ckeditor/ckeditor5-paste-from-office npm

    Plages de versions concernées
    • SEMVER: < 27.0.0

    Mettez à jour vers 27.0.0

  • @ckeditor/ckeditor5-widget npm

    Plages de versions concernées
    • SEMVER: < 27.0.0

    Mettez à jour vers 27.0.0

  • ckeditor3 Ubuntu:18.04:LTS

    Versions du logiciel
    • 3.6.6.1+dfsg-1
    Plages de versions concernées
    • ECOSYSTEM: (−∞, +∞)

    Aucun correctif publié

  • ckeditor3 Ubuntu:20.04:LTS

    Versions du logiciel
    • 3.6.6.1+dfsg-3
    • 3.6.6.1+dfsg-4
    Plages de versions concernées
    • ECOSYSTEM: (−∞, +∞)

    Aucun correctif publié

  • ckeditor3 Ubuntu:22.04:LTS

    Versions du logiciel
    • 3.6.6.1+dfsg-7
    Plages de versions concernées
    • ECOSYSTEM: (−∞, +∞)

    Aucun correctif publié

  • ckeditor3 Ubuntu:24.04:LTS

    Versions du logiciel
    • 3.6.6.1+dfsg-7
    Plages de versions concernées
    • ECOSYSTEM: (−∞, +∞)

    Aucun correctif publié

Sources originales

Vérifiez votre serveur →