CVE-2021-21391
CVE-2021-21391 · Regular expression Denial of Service in multiple packages
This page contains facts from public vulnerability sources. Check the original advisory before updating.
CKEditor 5 provides a WYSIWYG editing solution. This CVE affects the following npm packages: ckeditor5-engine, ckeditor5-font, ckeditor5-image, ckeditor5-list, ckeditor5-markdown-gfm, ckeditor5-media-embed, ckeditor5-paste-from-office, and ckeditor5-widget. Following an internal audit, a regular expression denial of service (ReDoS) vulnerability has been discovered in multiple CKEditor 5 packages. The vulnerability allowed to abuse particular regular expressions, which could cause a significant performance drop resulting in a browser tab freeze. It affects all users using the CKEditor 5 packages listed above at version <= 26.0.0. The problem has been recognized and patched. The fix will be available in version 27.0.0.
CVSS 6.5 · Medium · EPSS 1.7% · Fix available
- Published
- Updated
Affected products and versions
ckeditor5
- Versions
- < 27.0.0: Affected
No fix published
@ckeditor/ckeditor5-engine npm
- Affected ranges
- SEMVER: < 27.0.0
Update to 27.0.0
@ckeditor/ckeditor5-font npm
- Affected ranges
- SEMVER: < 27.0.0
Update to 27.0.0
@ckeditor/ckeditor5-image npm
- Affected ranges
- SEMVER: < 27.0.0
Update to 27.0.0
@ckeditor/ckeditor5-list npm
- Affected ranges
- SEMVER: < 27.0.0
Update to 27.0.0
@ckeditor/ckeditor5-markdown-gfm npm
- Affected ranges
- SEMVER: < 27.0.0
Update to 27.0.0
@ckeditor/ckeditor5-media-embed npm
- Affected ranges
- SEMVER: < 27.0.0
Update to 27.0.0
@ckeditor/ckeditor5-paste-from-office npm
- Affected ranges
- SEMVER: < 27.0.0
Update to 27.0.0
@ckeditor/ckeditor5-widget npm
- Affected ranges
- SEMVER: < 27.0.0
Update to 27.0.0
ckeditor3 Ubuntu:18.04:LTS
- Versions
- 3.6.6.1+dfsg-1
- Affected ranges
- ECOSYSTEM: (−∞, +∞)
No fix published
ckeditor3 Ubuntu:20.04:LTS
- Versions
- 3.6.6.1+dfsg-3
- 3.6.6.1+dfsg-4
- Affected ranges
- ECOSYSTEM: (−∞, +∞)
No fix published
ckeditor3 Ubuntu:22.04:LTS
- Versions
- 3.6.6.1+dfsg-7
- Affected ranges
- ECOSYSTEM: (−∞, +∞)
No fix published
ckeditor3 Ubuntu:24.04:LTS
- Versions
- 3.6.6.1+dfsg-7
- Affected ranges
- ECOSYSTEM: (−∞, +∞)
No fix published
Original sources
- https://www.npmjs.com/package/%40ckeditor/ckeditor5-markdown-gfm
- https://github.com/ckeditor/ckeditor5/security/advisories/GHSA-3rh3-wfr4-76mj
- https://www.npmjs.com/package/%40ckeditor/ckeditor5-engine
- https://www.npmjs.com/package/%40ckeditor/ckeditor5-font
- https://www.npmjs.com/package/%40ckeditor/ckeditor5-image
- https://www.npmjs.com/package/%40ckeditor/ckeditor5-list
- https://www.npmjs.com/package/%40ckeditor/ckeditor5-media-embed
- https://www.npmjs.com/package/%40ckeditor/ckeditor5-paste-from-office
- https://www.npmjs.com/package/%40ckeditor/ckeditor5-widget
- https://nvd.nist.gov/vuln/detail/CVE-2021-21391