p PatchFirst

CVE-2022-24858

CVE-2022-24858 · Default redirect callback vulnerable to open redirects

Esta página presenta datos de fuentes públicas de vulnerabilidades. Consulta el aviso original antes de actualizar.

next-auth v3 users before version 3.29.2 are impacted. next-auth version 4 users before version 4.3.2 are also impacted. Upgrading to 3.29.2 or 4.3.2 will patch this vulnerability. If you are not able to upgrade for any reason, you can add a configuration to your callbacks option. If you already have a `redirect` callback, make sure that you match the incoming `url` origin against the `baseUrl`.

CVSS 6.1 · Media · EPSS 0,8% · Corrección disponible

Publicación
Actualización

Pila tecnológica: node

Productos y versiones afectados

  • next-auth

    Versiones
    • < 3.29.2, < 4.3.2: Afectada

    Sin corrección publicada

  • next-auth npm

    Intervalos de versiones afectados
    • SEMVER: < 3.29.2

    Actualiza a 3.29.2

  • next-auth npm

    Intervalos de versiones afectados
    • SEMVER: ≥ 4.0.0, < 4.3.2

    Actualiza a 4.3.2

Fuentes originales

Comprueba tu servidor →