p PatchFirst

CVE-2022-24858

CVE-2022-24858 · Default redirect callback vulnerable to open redirects

Diese Seite enthält Fakten aus öffentlichen Sicherheitsquellen. Lesen Sie vor dem Aktualisieren die Originalmeldung.

next-auth v3 users before version 3.29.2 are impacted. next-auth version 4 users before version 4.3.2 are also impacted. Upgrading to 3.29.2 or 4.3.2 will patch this vulnerability. If you are not able to upgrade for any reason, you can add a configuration to your callbacks option. If you already have a `redirect` callback, make sure that you match the incoming `url` origin against the `baseUrl`.

CVSS 6.1 · Mittel · EPSS 0,8% · Korrektur verfügbar

Veröffentlicht
Aktualisiert

Technologie-Stack: node

Betroffene Produkte und Versionen

  • next-auth

    Softwareversionen
    • < 3.29.2, < 4.3.2: Betroffen

    Keine Korrektur veröffentlicht

  • next-auth npm

    Betroffene Versionsbereiche
    • SEMVER: < 3.29.2

    Auf 3.29.2 aktualisieren

  • next-auth npm

    Betroffene Versionsbereiche
    • SEMVER: ≥ 4.0.0, < 4.3.2

    Auf 4.3.2 aktualisieren

Originalquellen

Prüfen Sie Ihren Server →