p PatchFirst

CVE-2022-24858

CVE-2022-24858 · Default redirect callback vulnerable to open redirects

This page contains facts from public vulnerability sources. Check the original advisory before updating.

next-auth v3 users before version 3.29.2 are impacted. next-auth version 4 users before version 4.3.2 are also impacted. Upgrading to 3.29.2 or 4.3.2 will patch this vulnerability. If you are not able to upgrade for any reason, you can add a configuration to your callbacks option. If you already have a `redirect` callback, make sure that you match the incoming `url` origin against the `baseUrl`.

CVSS 6.1 · Medium · EPSS 0.8% · Fix available

Published
Updated

Stack: node

Affected products and versions

  • next-auth

    Versions
    • < 3.29.2, < 4.3.2: Affected

    No fix published

  • next-auth npm

    Affected ranges
    • SEMVER: < 3.29.2

    Update to 3.29.2

  • next-auth npm

    Affected ranges
    • SEMVER: ≥ 4.0.0, < 4.3.2

    Update to 4.3.2

Original sources

Check your server →